ONTAP Discussions

Inquire about Visual Studio 2005 compatibility in NetApp CIFS environment

SungduckYoon
202 Views

Dear All

 

I recently came across an unusual situation.

The customer's environment is as follows.
1. NetApp FAS8300 / CIFS Used (SMB1,SMB2,SMB3 ON)
2. ONTAP is 9.9.1P5
3. The customer's PC is Windows XP and uses Visual Studio 2005.

All basic functions such as access to NetApp CIFS and copy/delete work well on the customer's PC.

However, both project creation and project storage locations in Visual Studio 2005 can be saved to NetApp CIFS Share.
However, when Build (compile) is executed, it immediately fails with Access is Denied.
Strange thing is that it works fine on OLD NAS (Hitachi), but not on NetApp.

Thinking of a permission problem, I tried to proceed with the Test Volume with Everyone permission, but Build (Complie) does not proceed as described above.

The error is the same Access is denied .

 

I would like to know if anyone has had a similar experience and solved it.

 

The message is as follows, and even if you look at the file, there is no unusual message, and it does not proceed after the message access is denied.


1>------ Build started: Project: TestClass1, Configuration: Debug Win32 ------
1>Creates OAI_BuidInfo.txt
1>Access is denied.
1>Project : error PRJ0002 : Error result 1 returned from 'C:\WINDOWS\system32\cmd.exe'.
1>Build log was saved at "file://t:\test\TestClass1\TestClass1\Debug\BuildLog.htm"
1>TestClass1 - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

7 REPLIES 7

elementx
183 Views

> t:\test\TestClass1\TestClass1\Debug\BuildLog.htm

 

Is that log this file? If not, what does the log file say?

Can you build with verbose logging?

Did you check ONTAP-side log on this SMB share?

1. verboes log (visual Studio 2005)

Build Log
Rebuild started: Project: CPLEIP_TEST, Configuration: Release|Win32

Command Lines Creating temporary file "w:\PRODUCT_ANALYSIS_sanguck_ahn_CoreIP_T2K\S5WT208X01_T2000\S5WT208X01_Kiwi\TestClasses\src\CPLEIP_TEST\Release\BAT00000621843052.bat" with contents
[
@echo off

@Echo off

echo Version:1.00> "w:\PRODUCT_ANALYSIS_sanguck_ahn_CoreIP_T2K\S5WT208X01_T2000\S5WT208X01_Kiwi\TestClasses\src\CPLEIP_TEST\OAI_BuildInfo.txt"

echo Solution:"W:\PRODUCT_ANALYSIS_sanguck_ahn_CoreIP_T2K\S5WT208X01_T2000\S5WT208X01_Kiwi\TestClasses\src\CPLEIP_TEST\CPLEIP_TEST.sln">> "w:\PRODUCT_ANALYSIS_sanguck_ahn_CoreIP_T2K\S5WT208X01_T2000\S5WT208X01_Kiwi\TestClasses\src\CPLEIP_TEST\OAI_BuildInfo.txt"

echo Project:"W:\PRODUCT_ANALYSIS_sanguck_ahn_CoreIP_T2K\S5WT208X01_T2000\S5WT208X01_Kiwi\TestClasses\src\CPLEIP_TEST\CPLEIP_TEST.vcproj">> "w:\PRODUCT_ANALYSIS_sanguck_ahn_CoreIP_T2K\S5WT208X01_T2000\S5WT208X01_Kiwi\TestClasses\src\CPLEIP_TEST\OAI_BuildInfo.txt"

 

if errorlevel 1 goto VCReportError

goto VCEnd

:VCReportError

echo Project : error PRJ0019: A tool returned an error code from "Creates OAI_BuidInfo.txt"

exit 1

:VCEnd
]
Creating command line "w:\PRODUCT_ANALYSIS_sanguck_ahn_CoreIP_T2K\S5WT208X01_T2000\S5WT208X01_Kiwi\TestClasses\src\CPLEIP_TEST\Release\BAT00000621843052.bat"

Output Window
Creates OAI_BuidInfo.txt
Access is denied.
Project : error PRJ0002 : Error result 1 returned from 'C:\WINDOWS\system32\cmd.exe'.

Results
Build log was saved at "file://w:\PRODUCT_ANALYSIS_sanguck_ahn_CoreIP_T2K\S5WT208X01_T2000\S5WT208X01_Kiwi\TestClasses\src\CPLEIP_TEST\Release\BuildLog.htm"
CPLEIP_TEST - 1 error(s), 0 warning(s)

 

2. ONTAP-side is no log ( command : set d ; event log show )

 

Thanks...

From that MS forum link, I'd try the Autorun suggestion and consider if this may be the problem:

 

> the error message most likely means that cmd.exe is not in the path that the build process is launched with. this path is taken from tools->options->projects and solutions->vc++ directories, 'executable paths'. the default has $(path) as the last value so that it uses your system path, which ought to include the path to cmd.exe.

 

Maybe other NAS has entries for their paths, and the ONTAP path does not?

 

Other than that, I don't know what else I'd check.

Dear elementx

 

Thank you for a detailed description.

We want to help other people see this
Additional information about the path will be provided.

Unfortunately, I couldn't find the cause even in the path check.
The reason is
1. With the same path (currently W:), I tried to run both the OLD NAS and the NetApp NAS the same.
2. At this time, the OLD NAS ran normally, but the build did not work on the NetApp NAS.
3. I also ran it on Windows XP C:\, and this also had no problems.

In addition, I saved (saved) the project creation and storage, not the existing source, to the NetApp NAS, and the project was built without any changes, but at this time, " Access denied " also occurs.

 

 

 

Sorry to hear that. In the past I've dealt with similar mysteries and I had to capture very low level traces - it took me days to figure it out. (It wasn't with ONTAP, but eventually the reason turned out to be a known, obscure issue in Bash built for MinGW (MSYS) on the client, but it didn't affect other NAS! I know there's no Bash here,  but my point is there's a very small chance there's an ONTAP-only bug on the client, or a rare NAS issue that affects only this application).

 

At this point I'd contact  Support to get their opinion.

 

It would be good if you could ask the user to create a new minimal "hello world" project  - if that works, then it's project-specific, and if it doesn't, then it's better because you can share this hello world project with Support. Because you probably won't be able to get customer's source code for Support to duplicate the issue in their environment.

Ontapforrum
178 Views

You might want to try some suggestion via Microsoft forum.

https://social.msdn.microsoft.com/Forums/en-US/871103ca-6015-40ce-8a59-92e47ce68aeb/error-prj0002-error-result-1-returned-from-cwindowssystem32cmdexe?...

 

 

(I am afraid, but it's not a Storage issue. ONTAP 9.9.1P5 don't support Windows XP as a client (Infact the entire 9.x don't support). Also, VS 2005 official support has also ended in 2016 by Microsoft, as I read on the internet). Attached ONTAP & XP support matrix.

Dear ontapforrum

I know there is no compatibility support.
However, it works correctly in the existing storage (Hitachi) and At NetApp, failing is the biggest concern.

Thanks.

Public