ONTAP Discussions

Highlighted

Netapp Routing

Hi,

can someone help me with the routing? I have the following network configuration:
Filer 1: Group e0a, e0c Ip: 10.140.11 .......
                Group e0b, 0ed Ip: 10.140.21 .......
                Mgmt e0m Ip: 10.140.15 .......
Filer 2: same config, only other IP
Default Gateway: 10.140.11.254

Client 1: ip: 10.140.15 ........ netapp on MGMT ping successfully
               - ping on 10.140.21 ....... not successful
               - ping to 10.140.11 ....... not successful

Client 2: ip: 10.140.31 ........ ping to 10.140.15 ..... not successful
                                                   ping to 10,140.21 ..... not successful
                                                   ping on 10.140.11 ..... not successful

I can ping the MGMT from client 1, I realize. Both are in the same subnet. But why do not I reach the others? Does something have to be stored in the Netapp routing table?

Please help.

14 REPLIES 14
Highlighted

Re: Netapp Routing

Maybe show the full info if you want to share:

net int show

route show

broadcast-domain show

Highlighted

Re: Netapp Routing

Hi,

route -s -> see attachment

Unfortunately, the other commands are not available for me. (See attachement).

Highlighted

Re: Netapp Routing

An. you are on 7-mode. That changes a bit:

(from BOTH nodes)

 

ifconfig -a

ifgrp status

and this too:

rdfile /etc/rc

Highlighted

Re: Netapp Routing

See attachement

Highlighted

Re: Netapp Routing

See attachement

Highlighted

Re: Netapp Routing

Is the issue resolved ?

 

I see the default gateway is : 10.140.11.254 [Can you ping this ?]


Can you ask your network guys, if e0M can talk to 10.40.21.x via 10.140.11.254 , or you need a router at separate address ?


In any case, this is the command to add 'route':

 

The syntax for route add in 7-mode is :

route add < host/net > < gateway > < metric >
route add 10.0.0.1 192.168.1.250 1


https://kb.netapp.com/app/answers/answer_view/a_id/1034531/loc/en_US#__highlight

Highlighted

Re: Netapp Routing

Hi,

No. Unfortunately not quite. The ping of my client 10.140.31 .... on the e0m 10.140.15.211 arrives but unfortunately not on the interfaces StorageLAN 10.140.21.211 and ProdLAN 10.140.11.211.

If I ping from the netapp on the networks 10.140.31 ... and 10.101.11 .... run, it all depends.

Excerpt from my routing table (see attachment)

Highlighted

Re: Netapp Routing

Ok, I think I might have this.

Node1

e0M -> 10.140.15.211/24

StorLAN -> 10.140.21.211/24

ProdLAN -> 10.140.11.211/24

Default route -> 10.140.11.254

 

Node1

e0M -> 10.140.15.212/24

StorLAN -> 10.140.21.212/24

ProdLAN -> 10.140.11.212/24

Default route -> 10.140.11.254

 

What this config tells me is this:

UNLESS you have a client IP on 10.140.15.x, you cannot ping this interface.

UNLESS you have a client IP on 10.140.21.x, you cannot ping this interface.

 

The default gateway is 10.140.11.254 which is on the ProdLAN ifgrp.

ANY communication INTO the NetApp, will result in going OUT THE ProdLAN interface.

 

That is why your Pings are failing. Host 10.140.31.x going to the NetApp (no matter the incoming interface), if it makes it, returns out the ProdLAN where it may not be able to find it end unit.

 

What you need to do is determine which interface you really want to be your default Gateway.

Then re-order your /etc/rc files.

 

ifconfig <interface> blah.....

route add <blah>

ifconfig #2

ifconfig #3

 

You have defined the default to the be 10.140.11.254 on ProdLAN,  yet according to "route" it is trying to use 10.140.15.254 on e0M.

 

Figure which one, correct it and reboot the nodes.

 

Highlighted

Re: Netapp Routing

Sorry, but somehow it does not understand. I have made the changes (see attachment), but I can not reach the 10.140.11.211 from the 10.140.31 / 24 network by ping.

Highlighted

Re: Netapp Routing

Highlighted

Re: Netapp Routing

ok. Thanks for the update.

 

Could you give us the following info:

 

1) rdfile /etc/rc
2) netstat -rn
3) netstat -x
4) options ip.fastpath.enable

 

Client 1: ip: 10.140.15.xx
tracert 10.140.15.211
tracert 10.140.11.211
tracert 10.140.21.211
Ping 10.140.11.254

Ping 10.140.15.254


Client 2: ip: 10.140.3.xx
tracert 10.140.15.211
tracert 10.140.11.211
tracert 10.140.21.211
Ping 10.140.11.254

Ping 10.140.15.254

Highlighted

Re: Netapp Routing

See attachement

Highlighted

Re: Netapp Routing

Hi,

it's up to the group. If I delete the group and the e0a assigns the 10.140.11.211 the ping works.

What could I have done wrong during group creation?

Highlighted

Re: Netapp Routing

To start, re-org your rc files like this (moving the interface and default GW to the first lines to config)

hostname lvs-stor-0x
ifgrp create single StorageLAN e0b e0d
ifgrp create LACP ProdLAN -b ip e0a e0c

ifconfig StorageLAN ....
route add default 10.140.11.254.1

ifconfig ProdLAN ...
ifconfig e0M ...
routed on
options dns.domainname awolvsa.local
options dns.enable on
options nis.enable off
savecore

Second, according to the ifgrp-status earlier, you LACP is inactive. Is the switch setup correctly to do LACP?

If you are disabling the IFGRP and using a single port, then the switch is not setup to do LACP on those two ports.

Either correct the switch and use the IFGP with LACP or use "single" for ProdLAN also.

 

View solution in original post

Check out the KB!
NetApp Insights To Action
All Community Forums