ONTAP Discussions

No metrics regarding SnapMirror with Harvest

Street573

Hello all,  I'm posting here since Harvest's Github page seems to be reserved for bug reports and feature requests.

We're using Harvest to monitor our NetApp systems, associated with Prometheus and Grafana.
Everything is working fine, except for Snapmirrors, where I can't collect anything it seems.
I use the "readonly" role with Harvest to collect metrics (which has almost full access to /api), I've tried to create a custom role with /api/snapmirror readonly access, but this doesn't change anything, when I access http://<harvest_ip>:12991/metrics. I don't get anything regarding snapmirrors.

I've tried to see if I had any logs with the snapmirror module with this command :
$ harvest start cluster-01 --foreground --verbose --collectors zapi --objects SnapMirror
But no WARN of ERR lines. 

The metrics page only display me metadata in this case :
metadata_component_status{poller="cluster-01",version="21.05.4",hostname="REDACTED",type="exporter",name="Prometheus",target="prometheus1",reason="initialized"} 0
metadata_component_count{poller="cluster-01",version="21.05.4",hostname="REDACTED",type="exporter",name="Prometheus",target="prometheus1",reason="initialized"} 0
metadata_component_status{poller="cluster-01",version="21.05.4",hostname="REDACTED",type="collector",name="zapi",target="SnapMirror",reason="running"} 0
metadata_component_count{poller="cluster-01",version="21.05.4",hostname="REDACTED",type="collector",name="zapi",target="SnapMirror",reason="running"} 0
metadata_target_status{poller="cluster-01",version="21.05.4",hostname="REDACTED",addr="REDACTED"} 0
metadata_target_ping{poller="cluster-01",version="21.05.4",hostname="REDACTED",addr="REDACTED"} 0.178
metadata_target_goroutines{poller="cluster-01",version="21.05.4",hostname="REDACTED",addr="REDACTED"} 10
metadata_exporter_time{poller="cluster-01",exporter="Prometheus",target="prometheus1",hostname="REDACTED",version="21.05.4",task="http"} 586
metadata_exporter_count{poller="cluster-01",exporter="Prometheus",target="prometheus1",hostname="REDACTED",version="21.05.4",task="http"} 9

Is there something to activate in our NetAPP system to get metrics on SnapMirrors?
What might be the problem?

Regards.

1 REPLY 1

Street573

Nobody has any idea? 😕
Is this the right place to ask?

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public