ONTAP Discussions

Running 'quota' from Linux clients


We just upgraded to cDOT 8.2.1p2 from 7-mode 8.1.  There are, as expected, a few hiccups.  One of the user-facing ones is this response when users run the 'quota' command on any of our Linux clients (we're an all-NFSv3 environment):

quota: error while getting quota from $filer:/vol/home/0 for $user (id $id): Connection refused

I can tell that the daemon is running on the svm from both the client and filer sides:

$rpcinfo -p $filer

    program vers proto   port  service



    100011    1   udp   4049  rquotad

::> network connections listening show -node $node1

Vserver Name     Interface Name:Local Port              Protocol/Service

---------------- -------------------------------------  -----------------------

Node: $node1


. $filer       data1:4049                             UDP/unknown

None of the firewall options I can find deal with anything other than basic services.  Does anybody have any hints as to how to open this up?  Thanks.



Ah, found it.  Issue this command for every svm:

nfs modify -vserver $SVM_NAME -rquota enabled

View solution in original post



Ah, found it.  Issue this command for every svm:

nfs modify -vserver $SVM_NAME -rquota enabled


Thank you for the hint, I however still cannot make it working with NFSv4 where I still get a "connection refused" message ( in CDOT 8.2 ).


What the clients see:

rpcinfo -p $FILER

100000 2 udp 111 portmapper
100000 2 tcp 111 portmapper
100003 3 udp 2049 nfs
100003 3 tcp 2049 nfs
100003 4 tcp 2049 nfs
400010 1 tcp 2049
100005 1 udp 635 mountd
100005 2 udp 635 mountd
100005 3 udp 635 mountd
100005 1 tcp 635 mountd
100005 2 tcp 635 mountd
100005 3 tcp 635 mountd
100021 4 udp 4045 nlockmgr
100021 4 tcp 4045 nlockmgr
100024 1 udp 4046 status
100024 1 tcp 4046 status
100011 1 udp 4049 rquotad



What the filer sees:

network connections listening show -node $FILER-01


Vserver Name Interface Name:Local Port Protocol/Service
---------------- ------------------------------------- -----------------------
Node: $FILER-01
$VSERVER lif1:4049 UDP/unknown


My configuration is as this


$VSERVER::> vserver nfs show -instance

Vserver: XXX
General NFS Access: true
NFS v3: enabled
NFS v4.0: enabled
UDP Protocol: enabled
TCP Protocol: enabled
Spin Authentication: disabled
Default Windows User: -
NFSv4.0 ACL Support: enabled
NFSv4.0 Read Delegation Support: disabled
NFSv4.0 Write Delegation Support: disabled
NFSv4 ID Mapping Domain: XX.XX.XX
NFSv4.1 Minor Version Support: disabled
Rquota Enable: enabled
NFSv4.1 Parallel NFS Support: disabled
NFSv4.1 ACL Support: disabled
NFS vStorage Support: disabled
Default Windows Group: -
NFSv4.1 Read Delegation Support: disabled
NFSv4.1 Write Delegation Support: disabled
NFS Mount Root Only: enabled
NFS Root Only: disabled
NFSv3 MS-DOS Client Support: disabled


Does anyone have a hit on what's happening?


Kind regards








I am a client user and I wonder if it is not possible to get my quota report by simple Linux tool like quota.

The network admin says that it is not possible for client to get quota report. Only on filer itself the report could be generated by the admin.


If I try df . I get sometimes a correct report and sometimes only trash report. In a different thread it was mentioned that df is not suitable for netapp.

“As far as I know (and I could be wrong), df in Unix has never reflected user quotas, it always shows the size of the file system. This is the same whether the file system is local or over NFS. A qtree quota is different because it makes the OS think that the "disk" has a restricted size. The "quota" command, however, should display the quota size and usage for a given user.”


No I tried the quota command on my terminal.

I get the same error message as mentioned in the thread above.


My question:

Could the admin setup the netapp filer in the way that my quota request is not refused?


Thank you in advance!


Best regards