ONTAP Discussions

SDCLI + Windows Cluster


Has anyone managed to get SDCLI to successfully create a disk for a Windows cluster?  I get the error "Input either new resource group name or existing group name and not both ...", I have tried using both new and existing group names but I get the same error.

The command is;

SDCLI.exe disk create -d j -p <filername>:/vol/test/cli_test -z 100MB -I <hostname1> <iqn1> <hostname2> <iqn2>  -dtype shared

I can run the following command individually on the respective hosts without issue;

SDCLI.exe disk create -d j -p <filername>:/vol/test/cli_test -z 100MB -I <hostname1> <iqn1> -dtype dedicated

So the only change is -dtype to shared, and adding a pair to the -I switch.

I have tried using -IG too and I have tried pre-creating igroups or having no pre-existing igroups, but whatever I try doesn't seem to let me create a shared disk.  I can create a disk fine with the GUI.


Re: SDCLI + Windows Cluster

I got a response to this from a NetApp engineer...

The lesson is to read the full manual and not assume anything

I was missing the -e or -n switch, that is required for shared disks so SnapDrive knows which storage group in the cluster to assign the storage to, e.g.

SDCLI.exe disk create -d j -p :/vol/test/cli_test -z 100MB -I hostname1 iqn1 hostname2 iqn2 -dtype shared -e "Available Storage"

Cloud Volumes ONTAP
Review Banner
All Community Forums