Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

ONTAP Discussions

Showmount showing the volume after the exporting Only qtree in CDOT

SrinathATT

I am running on 8.3.1 cdot

 

I have a vol ( test1) with qtree(qtree1) (qtree2), Created export policy and rulles.

 

Exported the NAS share by adding rules to just the qtrees. I've modfied volume's export policy as (no_one).

 

But when i go the server and do a showmount -e (filerIP) i see the volume which i should not....Can anyone suggest resolution?

Server is RHEL 6.X and seeing output as below.

/test1 (everyone)

/test1/qtree1 (everyone)

/test1/qtree2 (everyone)

 

My requirement is Server should not see the vol except the qtrees whichi exported.

 

--Srinath

1 ACCEPTED SOLUTION

SrinathATT

Here is the Resolution for this..

 

 

https://kb.netapp.com/support/s/article/ka21A0000008rnUQAQ/how-does-showmount-work-with-clustered-data-ontap?language=en_US

 

There are seperate tasks which are under 8..3 and later.

 

Cheers!!

 

Happy troubleshooting!@@

View solution in original post

6 REPLIES 6

parisi

There is no way to hide the volume in showmount in cDOT, as you have to export the parent volume to be able to access the qtree.

ghislanzoni

Hi,

in Cluster Mode you need to enable the showmount option:

 

 nfs modify -vserver vserver_name -showmount enabled

 

Regards

Roberto

SrinathATT

Yes . I've enabled the showmount option which allowed the client server see the all the NFS shares including the vol which was not exported as well..

I am trying to hide that volume and allow only qtrees.

 

/test1 (everyone)    ==> I dont want him to view this.

/test1/qtree1 (everyone) => exported to client server

/test1/qtree2 (everyone) => exported to client server

 

Thank you

parisi

As mentioned in the post above yours, it is not possible to hide volumes in showmount output.

SrinathATT

Is this issue yet to be fixed on any latest version? I am really hearing that this can be controlled in nfs v4. Can anyone brief on it how it can be done?

 

Regards,

Srinath

SrinathATT

Here is the Resolution for this..

 

 

https://kb.netapp.com/support/s/article/ka21A0000008rnUQAQ/how-does-showmount-work-with-clustered-data-ontap?language=en_US

 

There are seperate tasks which are under 8..3 and later.

 

Cheers!!

 

Happy troubleshooting!@@

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public