ONTAP Discussions

SnapManager for SQL fails to mount SnapShot


We are running SMSQL version 5.1 and I am trying to run a normal daily backup of one of my SQL servers.  I am running exactly the same scripts etc on all my other servers with success but this one is causing me massive problems.

As you can see from the extract below the backup is failing to mount the snapshot.  Does anybody have any idea why this is happening?  I have tried all manner of things to try to resolve this but all has been futile.

For example I have checked the C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint to see if there was a 'stuck' mount point which there wasn't.  I also stopped and restarted the SnapDrive & SnapManager services which sometimes resolves minor issues.  This didn't.  I then re-ran the Configuration Wizard which also proved futile.

[15:13:03.032]  Collecting verification information...
[15:13:03.032]  Getting database backup information from SnapInfo file...
[15:13:03.032]  Running verification from local server....
[15:13:03.048]  Mounting Snapshot [sqlsnap__XXXXXsql01_07-03-2012_15.12.04] for LUN [C:\mount\VCDB\] of Computer [XXXXXSQL01]
[15:13:03.048]  SnapManager will use directory [C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint] to mount snapshot [sqlsnap__XXXXXsql01_07-03-2012_15.12.04]
[15:13:03.048]  Mount point directory [C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint]
[15:13:03.048]  Snapshot will be mounted on subdirectory [MPDisk001]
[15:16:01.225]  [SnapDrive Error]: Failed to mount backup sqlsnap__XXXXXsql01_07-03-2012_15.12.04. Reasons Failed to mount disk (Disk Id <6000C296-13d0-6069-6923-1255c0f689d8>) in Backup <7a632ecc-da7f-4847-9c53-d010055d839b>. Server Error: <Mounting the backup sqlsnap__XXXXXsql01_07-03-2012_15.12.04 failed with following reason: FLOW-11019: Failure in DatastoreMountActionWrapper: java.lang.NullPointerException>. .

(SnapDrive Error Code: 0xc0041057)
[15:16:01.225]  Unknown Error, Error Code: 0xc0041057
[15:16:01.225]  Database verification information was not updated.
[15:16:01.225]  There is an error during database verification.

[15:16:01.225]  **** FULL DATABASE BACKUP RESULT SUMMARY #1 ****
[15:16:01.225]  Backup Time: 07-03-2012_15.12.04

[15:16:01.225]  Backup Group [#1]:
[15:16:01.225]  #1 : [XXXXXSQL01\VIRTU - VCDB] : Failed with error code 0xc0041057.
[15:16:01.225]  #1 : [XXXXXSQL01\VIRTU - VCDB] Error : Backup OK, but DBCC Failed.
[15:16:01.225]  *** SNAPMANAGER BACKUP JOB ENDED AT: [07-03-2012 15.16.01]
[15:16:01.225]  The backup of one or more databases failed.

[15:16:01.225]  The SnapManager operation failed with the error: C00408D3.
[15:16:01.225]  'Skip post-command on operation error' is enabled, so post-command processing will now stop.

Please let me know if you require any additional information.

Any help with this would be gratefully appreciated.

Kind Regards


Re: SnapManager for SQL fails to mount SnapShot


Have you tried mounting the snapshot manualy? Does this work? Have you tried to mount the snapshot to a drive letter instead of the mount point?

Additional to the snapdrive service you could also try to restart the virtual disk service and retry.



View solution in original post

Re: SnapManager for SQL fails to mount SnapShot



Thank you so much for this.  To be honest I never even thought of trying such an obvious fix (restarting the Virtual Disk service).  This will now be entered into our SOPs for future reference.

Thanks again bud.


NetApp Insights to Action
I2A Banner
All Community Forums