The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to register at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

ONTAP Discussions

Snapshot in use, and cannot delete

netappmagic

I am trying to delete a snapshot, but getting following message:

Error: command failed: Snapshot is in use

 

I used the option: -ignore-owners true -force true

still the same error.

 

No Snapmirror, snapvault or clone associaetd with the volume

 

Any idea how to delete it?

4 REPLIES 4

ITSSANSTORAGE

We are still having the same problem too. Have tried to force delete the snaps with no sucess. Any further help appreciated.

 

::*> snap delete -vserver tur-nas1 -volume tur_nas1_streamv19_content -snapshot SP_2_1213666_7626_1460597749 -foreground true -force true -ignore-owners true

Error: command failed: Snapshot copy "SP_2_1213666_7626_1460597749" of volume "tur_nas1_streamv19_content" on Vserver "tur-nas1" has not expired or is locked. Use the "snapshot show -fields owners, expiry-time" command to view
the expiry and lock status of the Snapshot copy.

 

 

::*> snapshot show -fields owners,expiry-time -vserver tur-nas1 -volume tur_nas1_streamv19_content
vserver volume snapshot owners expiry-time
-------- -------------------------- ---------------------------- -------------- -----------
tur-nas1 tur_nas1_streamv19_content SP_2_1213666_7626_1460597749 "volume clone" -
tur-nas1 tur_nas1_streamv19_content test_snapshot_ian - -
tur-nas1 tur_nas1_streamv19_content snapmirror.02422c1b-4daf-11e4-8a7c-123478563412_2147484763.2018-02-28_143000

vietnetapp

There is no way that you can delete that busy snapshot.   you can't force or ignore-owner.

 

Please try these steps.   It works like a charm:

 

1. create new snapshot on the source cluster, label the snapshot properly so that the snapshot will be used for snapmirror

2. on the destination cluster, re-create the snapmirror job.

3. on the destinaiton cluster, run "snapmirror resync".  it will use the newly created snapshot for snapmirror and release the busy snapshot that you try to delete.

4. delete the "busy" snapshot (which is not busy anymore) on the destination volume.

joey_k

hello, have you resolve the issue? i have the same problem too,

Jeff_Yao
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public