ONTAP Discussions

Space Savings Estimation Tool - "Error 2"


I was not sure where to post a question regarding the Space Savings Estimation Tool, if this is incorrect, I can re-post elsewhere.

I am trying to use the Space Savings Estimation Tool, version 3, and am running into "Error 2".

Running on Windows 2008R2, 64bit (and that OS and bit maybe the problem), against a Netapp CDOT 8.2.1P3 (and perhaps CDOT is the problem).


The scan seems to work successfully, but then after the files are all processed this message is posted in the command window:

Scanning finished. Sorting the FP file.

Could not open the sorted fp file

: No such file or directory

Error 2


The fp file is created, and is the what I would guess to be a reasonable size (10GB) for the amount of data scanned, approximately 1.5TB and 800,000 files.


The command I am using is:

E:\SSET_Win_Linux\sset3_0_windows>find_space -ac -f y:\sset-log\fingerprint.fp -p z:\(directoryname) -T y:\sset-log\

Where e:\ is a local drive, y:\ is a NetApp CDOT CIFS share, and Z:\ is also a NetApp CDOT CIFS share (different volumes)


I also tried with the find_space.exe being on the CIFS share too:

Y:\sset3_0_windows>find_space -ac -f y:\sset-log\fp.fp -p z:\(directoryname) -T y:\sset-log\


The fp files are created, and are consistent in each run (I am running the tool against a static copy of the data I am interested in compressing).

03/12/2015 12:14 AM 10,846,795,971 fingerprint.fp

03/12/2015 10:07 PM 10,846,795,971 fp.fp


If the issue is the 64bit Windows OS, or CDOT, is there a way to run the tool just against the fp file now that it is created?


thanks for any suggestions,




Looks like you are running out of space. While running SSET, it creates the fp file, which is likely to be of the size that you specified. But, you may need 3 times that space on your device to successfully complete this task. For example, if the fp file is 10GB, the tool will take an additional 10gb for temporary files, and another 10GB for fp_sorted file. Thus you may need 30GB of free space. 

Please go through the following KB for details.


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.


If it is a free space issue, the tool does not seem to be doing what it is supposed to with the flags, since I had used the -f and -T options, which are supposed to put the fingerprint file and the temp files in the designated location. (Unless the free space is absolutely needed on the local C:\ drive, which I assumed it would not need since I told it to save the log and temp file to a different mapped drive.)

I am *not* getting the”;No Space Left on Device” error message, which the Readme says would be displayed if the temp space filled up.

In addition to the two previous runs, I tried this variation, running the find_space.exe from the same directory as where the log file set to be saved:

Y:\SSET-log>y:\sset-log\find_space -ac -f y:\sset-log\fp2.fp -p z:\(directoryname) -T y:\sset-log\

Where Y:\ is a NetApp CDOT CIFS share, and Z:\ is also a NetApp CDOT CIFS share
The fp2.fp2 is created on the y:\ drive.
The Y:\ drive has +300GB free.
I don't think it should matter, but the Z:\ drive does have +100GB free also.
The local drive only have about 15GB free.

Unfortunately the KB article you linked is restricted:

Article Not Found
The article was not found, is restricted to NetApp employees and partners, or is no longer available.

I suppose I'll try changing the Windows temp space to a remote location and trying again, but I am not getting an out of space message.


Well it does not seem to be a free space issue.  I set my %TEMP% directory to a mapped drive with 800GB free (same location as I am saving the fingerprint file), and got the same Error 2.

Is this tool supported?  Can I open a support case for it?


Command window output below, trimmed for brevity.


Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\user>echo %TEMP%

C:\Users\user>dir y:\
03/13/2015  12:06 PM    <DIR>          SSET-log
               8 Dir(s)  863,966,625,792 bytes free

C:\Users\user>Y:\sset-log\find_space -ac -f Y:\sset-log\fp3.fp -p Z:\directory -T Y:\sset-log\

Data ONTAP Space Savings Estimation Tool Version 3.0
1250 GB Scanned.
Number of files processed: 800000

Scanning finished.  Sorting the FP file.
Could not open the sorted fp file
: No such file or directory
Error 2

C:\Users\user>dir y:\
 Directory of y:\
03/17/2015  11:06 AM    <DIR>          SSET-log
               8 Dir(s)  853,067,100,160 bytes free

C:\Users\user>echo %TEMP%



I'm having the same issue with this tool. Keep getting the Error 2 message.  Thanks in advance for anyone that can provide insight and guidance!






I have the same problem


for the solution , go directory from cmd where sset is, run the command.