ONTAP Discussions

Troubleshooting with tcp_client

Euan

So, I have a node from one of our CDOT 9.1 clusters that all of a sudden can no longer reach the mail relay to send autosupport emails. I've checked DNS, IP routes, traceroute etc - all good - nothing has been changed on the filer,  the partner node still sends emails fine.

"you'll need to try a telnet to port 25 mate - can't help otherwise" they say...

TELNET? if only we had something that easy!

Wait - tcp_client - that used to work in 7-mode...

 

Yes - set diag mode, ensure diag user is unlocked, connected to node shell and set diag mode here.

Issued command and got an bind error:

 

tcp_client 4 <source IP for e0M> 25 <mail relay IP address> 25 -c 1 -s 1024

bind failed: Can't assign requested address

 

I've tried every IP allocated to this node of the cluster - same error.

Does anyone have any suggestions as to what I'm doing wrong or an alternative to troubleshooting open port connectivity from a pesky filer node?

1 ACCEPTED SOLUTION

Euan

What I should have done is spoken with my colleagues first who reminded me of the telnet command available through systemshell on each node;

 

remember to set diag mode and unlock the diag user.

CLUSTER::*> systemshell -node <NODENAME>

NODENAME% telnet <target ip> <port>

 

not sure why the tcp_client gives that error - but have the diagnostic I wanted.

Will leave this here so I can find it in another 12 months.

View solution in original post

1 REPLY 1

Euan

What I should have done is spoken with my colleagues first who reminded me of the telnet command available through systemshell on each node;

 

remember to set diag mode and unlock the diag user.

CLUSTER::*> systemshell -node <NODENAME>

NODENAME% telnet <target ip> <port>

 

not sure why the tcp_client gives that error - but have the diagnostic I wanted.

Will leave this here so I can find it in another 12 months.

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public