ONTAP Discussions

Version Flexible SnapMirror Not Transferring All Snapshots

TMADOCTHOMAS

We use version flexible snapmirror for all SnapMirror jobs, and we use a custom policy that includes the "all_source_snapshots" label. I recently set up two new volumes on a 9.3 system and replicated them to a 9.2 system. They worked fine until I needed to rename the source and destination volumes. After that change, the snapmirror jobs fail when run on a schedule (they work most of the time when I run them manually the next day). The errors complains that the snapmirror snapshot already exists on the destination. Even weirder, I just noticed that not all of the regular snapshots are being sent. There are 7 snapshots retained on both volumes, but only 5 of them show up for one of them and 6 for the other. Any ideas?

5 REPLIES 5

paul_stejskal

How big are the snapshots? My first guess is high change rate. Perhaps the snaps aren't rolling off fast enough if they are huge.

Thanks for replying Paul. The snapshots are very small, only MB in size. What makes it weirder is the missing snapshots are in the middle ... for example snapshots 0 and 1 are replicated, 2 is skipped, then 3 - 6 appear. Replication on one of the volumes failed last night. When I ran it this morning manually it was fine.

We probably need to look at some logs. Would it be possible to open a case?

 

If you can maybe share some of the snapmirror log files. If you aren't sure a case would be able to expedite troubleshooting.

Thanks Paul. Yeah it probably makes sense just to open a case. I will do that. Thanks for the help!

Sure thing. Glad to help.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public