ONTAP Discussions

statistics start is not working on OnTap 9.6p2?

heightsnj

 the following command is not working, so the "statistics show-periodic ..."

 

> statistics start

Error: "start" is not a recognized command

I tried both set d and set adv

 

Can somebody please advise?

6 REPLIES 6

pedro_rocha

Hello!

 

Be aware of this:

 

Availability: This command is available to cluster and Vserver administrators at the advanced privilege level.

 

So first, change to advanced:

cluster1::> set -privilege advanced
Warning: These advanced commands are potentially dangerous; use them only when directed to do so by technical support.
Do you wish to continue? (y or n): y
cluster1::*>

 

The following example starts statistics collection for sample "smpl_1":

cluster1::*> statistics start -object system -sample-id smpl_1
Statistics collection is being started for Sample-id: smpl_1

 

Check its documentation for more information: link to 9.6 commands 

 

Regards,

Pedro Rocha.

kahuna

"I tried both set d and set adv"

paul_stejskal

Are you at the cluster shell? It should look like "Cluster::>" and if you are in diag it should be "Cluster::*>".

kahuna

if he was on any shell other than the cluster shell, the error would be that 'statistics not found' and not 'start'

paul_stejskal

D'oh! Good point. O/P maybe we need to see a video of this?

 

Also does your user have rights to run the command (or are you logging in as admin)?

kahuna

it should work. Try '::*> statistics s' and hit the 'tab' key. It should show two options: 'start' and 'show'. Then try '::*> statistics st' and the 'tab' key

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

Public