ONTAP Hardware

Can you kill a TCP session in CLOSE_WAIT state?


Hi everyone,

I was wondering if anybody had encountered the following problem:  access using ssh,http or console to the filler stopped simultaneously although the rsh is still working.

As a result we can still manage the filler using rsh but not any other tools (including System Manager).

I've noticed that they are a whole bunch of tcp sessions in CLOSE_WAIT (more than 150) state from a single IP to the filler on port 443, andf I suspect that it might be the problem.

We're running NetApp Release on FAS 3200 but I've seen this behavior on some other versions as well and on some different hardware architecture like FAS 3020.

As soon as the filler is restarted everything starts working normal.

Any suggestions for how to kill this sessions, or is that possible at all?





Accumulating CLOSE_WAITs is normally indication of application bug – local side does not properly close connection after remote side did it. But 150 is not really that much.

As connections are apparently to web server, it could be possible to clear them by disabling and re-enabling httpd. But you should really open support case with NetApp as it sounds more like a bug.


We've tried to disable httpd that but didn't help. As a matter of fact a case was opened with NetApp but their recommendation is to restart the filler since they couldn't find any solution.



The filler was restarted and the problem..solved.

Altough I can't accept this as a solution I have to close this discussion since there's no nothing that it can be done.