ONTAP Hardware

Filers will not boot


Hi, I'm working with two FAS2020 filers, and neither will boot, not even to the special options menu.  They both fail with the error: PANIC: sanown: not enough filer table entries in process sanown_io on release Netapp Release

I've loaded and configured about 20 of these over the past few weeks, but this is the first time seeing this error.  Any help would be appreciated.






Did you try to turn the power down and removing all the disks from the system and power on? I think that both systems are confused with hardware or software based ownership with disks....

Remove all the disks and try to power the system in special boot menu...


That was somewhat helpfull.  Removing the drives allowed the controllers to boot and get to the special boot options, and I tried to run some of my normal setup stuff to overwrite whatever is causing the problem, but it doesn't get far enough into the process.  When I put the drives back in, it goes back to the original failure.  A couple things I'll try is just booting with drives only in the disk shelf, and then maybe some in the netapp itself.  I don't think this would be caused by a bad drive or drives though.  We'll see.



May be, images on CF are corrupted; have you tried to netboot known good version?


I tried your suggestion literally, but I think you mean for me to replace 'known good version' with a version number, which I don't have.  This is the initial startup for these controllers, so I don't have anything to roll back to, unfortunately.  Ironically, I would be installing an update if they would boot with drives in the netapp and disk shelf.



Well, as you say, you have now the option to boot in special boot menu.

Did you swap NVRAM Cards changing the System ID on the Filers?

Looks like very common problem with changing hardware or disks..

Once at a time

Connect with serial console cable on the first Node (FilerA) and try to upgrade disk ownerships on the disks (assign some disks) and create or use the (old root aggregate) and write if necessary a new root volume (vol0)

That you initial configure the filer, means that you lose all the informations (like licenses and configuration files)

That you have complete with this process (add all necessary licenses keys, and reboot one or more times), do the same for the second filer (FilerB)

Each node must have at least one root volume to boot successfully...

Please let me know if you have any other questions...




The process you've just described is how I'm loading each set of netapp controllers, though I have a .exe file written by someone else to automate it.  It was your first suggestion that actually led to the solution, though I'm not entirely sure why.  After learning that the filers would boot with no drives, I tried running the script which does all of the basic configurations and updates the version, but without the drives in it couldn't get that far.  So I tried it with just the disk shelf, then a couple drives in the fas2020, then a few more, and finally with all of them.  The setup script couldn't complete with missing drives, but at each boot it continued to make it past the point of the earlier failure.  Finally, with all of the drives in, the script ran and rebooted several times successfully, and is now running with no issues.  Thats great, but odd.  I had re-seated all of the drives after your first suggestion, so it seems unlikely that this was due to improperly seated drives, but why else would booting it with a few drives at a time eventually lead to a complete successful boot?

thanks for your help



Does this problem occured from an upgrade process? if yes, try to boot backup image


No, no upgrade.  This is the initial configuration for these two controllers, although they had been powered up by someone previously, but I don't think anyone ever did any kind of work on them.



Not sure the problem has been resolved.  If not, here're the steps which you might want to try:

1.  loader A> load-defaults

2.  loader A> bye

Next time filer will boot automatically.