ONTAP Hardware

Help! Cannot set up RSA in a FAS2240-2 Service Processor

rh
2,455 Views

Hi

 

I just configured RSA on the SPs of several filers quite happily but on another one I've run into an error that I've not seen before. The command "rsa status" gives:

 

SP> rsa status
Remote Support Agent is enabled.

Connection status:
HTTP : alert [ Internal error - unable to read
configuration ]
RSE : alert [ Internal error RSAD-280 - configuration
read failed ]

 

and the config I've entered (into "rsa setup") all looks good.

 

I ran a packet trace on the filer itself and I see no packets coming from the SP and certainly the above error messages imply that the RSA test process doesn't really get started.

 

Any ideas, please, how to diagnose these errors?

 

Thanks!

Richard.

4 REPLIES 4

HONIG2012
2,447 Views

have you tried to reboot SP?

which version are you running on your SP with which version of ONTAP?

 

thanks

-AJ

rh
2,427 Views
Sorry for omitting that: Filer is running 8.1.3P2 7-Mode SP details are: SP> version Booted primary firmware version 2.1.2 Booted primary ACP version 01.10 Primary firmware version 2.1.2 Primary ACP version 01.10 Backup firmware version 2.1.2 Backup ACP version 01.10 Even after "sp reboot", though, I still get: SP> rsa test Testing storage controller HTTP connection ......................... failed Internal error - unable to read configuration Testing Remote Support Enterprise connection ....................... failed Internal error RSAD-280 - configuration read failed One or more configuration tests failed. -- Richard.

HONIG2012
2,422 Views

please try to upgrade both service-processors to 2.1.3P2 which is compatible with 8.1.3 Ontap - perhaps that fixes your issue

Download and install instructions are here:

http://mysupport.netapp.com/NOW/download/tools/serviceimage/30603097_ontap/

 

good luck and feedback is welcome after upgrade 🙂

 

thanks

-AJ

rh
2,416 Views
AJ, Thanks for the suggestion -- I will try that and report back. Richard.
Public