ONTAP Hardware

Install Netapp harvest on openSUSE/SLES environment and resolve dependency issues.


I am in the process of installing NetApp harvest on an openSuse/SLES environment , SUSE Linux Enterprise Server 12 in particular. The instruction manual for the application shows the instructions for CentOS, Ubuntu, Debian etc, however there are no instructions for openSuse environment. I tried to manage with the same software dependency commands by using zypper instead of 'yum' or 'apt-get' with some of the commands in the instruction manual. 


I am not able run all the commands of the software dependencies. Furthermore, when installing the downloaded application, I am facing a lot of software dependency errors. Googling them did not help. 


So my questions are as follows.


1. Can NetApp Harvest be installed without any errors in OpenSUSE/SLES environment?


2. If yes, how do i resolve dependency issues? 




Please let me know of any suggestions



Why not just use NABox?




Thanks for the solution,


I am currently using NaBox and I am running all the platforms on a VMware ESXi host without VSphere or VCenter. After configuring the NaBox with its IP details, I went back into Open SUSE and ran the ip address in a browser with /admin to enter the GUI where I further installed harvest and Netapp NMSDK. I have reached a point where I need to enter details of the device that I need to harvest, where I need to enter details like hostname, Username and password. 

I understand a profile must be created, so to simulate this, I installed ONTAP edge on a virtual machine of VMware ESXi host. 

After I run Ontap edge it asks for the details as shown below.


Is the ESX host managed by a vCenter server? [y]: n

Enter ESX host name or IP address:

Enter ESX host username: root

Enter ESX host password: *******

Do you want to save this ESX server login information [y]: y


After this i get this error


LoginFailed: cannot login as "root" to "" - bad username or password


I doublechecked logging into Esxi and am sure that the credentials of the ESXi host is correct, but the error persists.


Later I used Ctrl+C and got into the terminal interface where i found another alternative of using the command 


esxcli --server --username root --vihost localhost.localdomain


and i get the error


Connect to failed with ssl error 0x8 


Furthermore, No setup was done for root access during the installation of the system.But the root password for sudo commands is unknown. What is the default root access password for the NetApp ONTAP Edge?


Am I missing something?

Is the process that i've taken right?

I do not have any physical NetApp hardware device with profiles such that i can feed metric data to NaBox. I want to run all these simulations virtually on ESXi.

Is there any other way to feed data to NaBox?




Wait a moment are you talking about harvest installation or ONTAP Select here?

Is that is your question NETAPP Select Host Configure Fails with Generic Error?


You should separate those topics; otherwise, it'll be a mess. Keep questions simple: one problem at a time.





I apologize for the exceedingly huge query.


As i said, I am running NaBox on my Vmware Esxi along with OpenSUSE as another VM. I've followed the procedure (https://nabox.org/documentation/) and after installing, there is a stage where I need to harvest a system (Check "Add your first system") from which i need to gather metric data. But currently I do not have hardware setup avaivable which I can readily harvest. I need another alternative, that can be done virtually as a VM and feed data to Nabox.


What can i do to simulate a physical hardware virtually that works similar to a NetApp physical device?


You can install either ONTAP Select or ONTAP Simulator.

The lest one have fewer requirements for the environment and can be installed on ESXi or even on VMware Workstation if needed.





Thank you very much. Works perfectly now.