ONTAP Hardware

Many DelayedWriteFailed errors while working with FAS3140 filer



My windows2008R2 server is working with a netapp filer (FAS 3140) as a NAS device.

During heavy load, every 1-2h there are errors in Windows system log about delayed write failed, in addition, many
errors are returned to the application.

The filer's event log do not have any clue on the errors.

I have  network trace (wireshark) covering the time of the error, where it is  evident that windows is closing the tcp connection with the filer.

Is there a documentation specifying the cases when windows redirector disconnects from NAS?



Offir -

Welcom to the NetApp communies site !

What is the CIFS oplocks setting for this qtree/volume ?

Do you have SMB 2.0 enabled ?

I hope this response has been helpful to you.

( even though all I did was ask questions...)

: )

At your service,

Eugene E. Kashpureff
Senior Systems Architect / NetApp Certified Instructor

(P.S. I appreciate points for helpful or correct answers.)



Oplocks are enabled (although I also tried disabling oplocks on one of the windows client machines - which still

produced errors).

I'm using smb1 - I saw considerable performance degradation when tried smb2.



this is odd. Please check your network switch logs for errors (packet drops, flapping MAC addresses, etc.) as in general, SMB2 performance should be AT LEAST equal to SMB1 performance, in almost all cases even better.

Also, if you have a vif/ifgrp configured on your netapp, check that it matches the port config on the switch (i.e. link aggregate/etherchannel/trunk if your ifgrp is of type MULTI, and NO link aggregate if your ifgrp is of type SINGLE)



Hello Offir,

we encounter a similar problem on our Windows Server 2008 R2 terminal servers in conjunction with our Netapp Metro Cluster and folder redirection. Have you ever found the cause of the problem and/or a solution?



I have the exact same problem. I use a CIFS share as a target mount path for SIMPANA. Under heavy load, some delayed write failed errors log in the system logs and the mount path goes offline.

For those who are still investigating, you can check the antivirus configuration. It can be the reason. Unfortunately it did not solve the problem for me.