ONTAP Hardware

Node rebooting after upgrade


Hi Team,

Need quick help if someone can on below:

It was two node metrocluster but due to business requirement we configured it as a single node (non-ha) system. Model: FAS8040. It was running fine with one node configuration since more then couple of years.

Today we did an upgrade from 8.3.1P1 to 9.1P10. As soon as we reboot the node. It is continually giving us below error and not booting ONTAP.

[rscnas01:fci.adapter.error:notice]: Fibre Channel adapter driver encountered error "disabling non-NetApp 8324 hardware" on 1a
[rscnas01:fci.adapter.error:notice]: Fibre Channel adapter driver encountered error "disabling non-NetApp 8324 hardware" on 1b
[rscnas01:kern.version.change:notice]: Data ONTAP kernel version changed from 8.3.1P1 to 9.1P10
CRITICAL: Metrocluster is configured but HAOSC is not configured correctly. Use the maintenance mode command "ha-config modify" on this node to correct the problem. This node cannot continue to boot and will now halt.

We verified ha-config show setting for both controller and chassis. Both are already set to "non-ha"

We also tried after removing the FCVI adapter hardware but its still giving us same above error.

Really appreciate Urgent help here.






Hi Arsalan,


You should remove the FCVI card if the system is no longer a MCC node - unless the card is in slot one AND the system is set as mcc, it will report this error under 9.1 and later. I see a similar case that resolved by powering the system down completely and then powering it back on. 


If that does not work, I would suggest you should contact our support center - our global contact numbers are listed on https://www.netapp.com/us/contact-us/support.aspx


Hope this helps!


Hi Alex,


Thanks for the reply. We did try by removing an FCVI card initially. Then we also tried by power down the controller and powering it UP but unfortunately it didnt work till now.

Any other suggestions ?


It was working since years but as soon as we did an upgrade and rebooted a node. It started complaining..





The documentation I've seen says: Remove the FCVI card, boot to maint mode, set ha-config to non-ha (even if it is already set), and halt the system. Power off then power on, and it should work.


If it does not, work with support to see what they can do.


When you are in the LOADER "update_flash" helps if the solution above does not work.