Object Storage

StorageGrid - unable to delete empty bucket

nicolasbegard

Hi,

 

In StorageGrid 11.5. We have one tenant with one bucket.

We deleted all datas on the bucket, but are unable to delete the bucket (and so the tenant), even if it says there is no space used and no objects in:

2021-11-05 10_05_59-Privileged Remote Access Console - axians.bomgarpam.cloud - BEGARD Nicolas.png2021-11-05 10_09_23-Privileged Remote Access Console - axians.bomgarpam.cloud - BEGARD Nicolas.png

 

One strange thing is that if I connect through a S3 browser, I can still see some datas in (after removing them), but I am unable to "delete"  them again...

Does someone already experience this kind of behaviour ?

Thanks !

1 ACCEPTED SOLUTION

ahmadm

 Hi nicolasbegard,

 

Thank you for the update. It seems like there is some metadata cleanup needed in order to delete the bucket. Were the objects deleted using S3 browser or using an ILM rule?

 

For next step, I think it is best to open a NetApp support case, so we can help track down some of the relevant metadata and determine the best approach to delete this bucket.

 

View solution in original post

4 REPLIES 4

ahmadm

 Hi nicolasbegard,

 

Thank you for the update. It seems like there is some metadata cleanup needed in order to delete the bucket. Were the objects deleted using S3 browser or using an ILM rule?

 

For next step, I think it is best to open a NetApp support case, so we can help track down some of the relevant metadata and determine the best approach to delete this bucket.

 

View solution in original post

Hi @ahmadm,

 

Files were deleted using the s3browser: seems it is not the better method 🙂

You are right, I will open a case and see what next.

Thanks again for your time !

nicolasbegard

Hi @ahmadm ,

 

Thanks for your feedback !

I can see the objects directly in  the bucket listing, and when I tried to download them, it fails with "object not found" message.

S3 object lock is not enabled.

Anyway, When I check the versions it seems I have some, but even If I tried to delete these, I have no feedback/ no error but still they are here.

I am working with free version of S3 browser, maybe I am facing limitation to this version, but still I can't get why in the admin page of the tenant I see  no objects in, and however it says "not empty bucket"...

nicolasbegard_0-1636364008716.png

 

Thanks for your help,

 

ahmadm
 
 

 

Where do you see the objects in S3 browser? Are they in the bucket listing? or are they only showing under versioning? And are those objects retrievable?

 

One possibility is if S3 object lock was enabled for the bucket and some of the object versions have a x-amz-object-lock-retain-until-date that has not been reached or legal hold. Do you know if S3 object lock is enabled on the bucket? (https://docs.netapp.com/sgws-115/topic/com.netapp.doc.sg-s3/GUID-F09B9F70-EAC2-489A-8D0B-D8ECD3E5D495.html)

 

Screen Shot 2021-11-05 at 7.58.53 AM.png

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public