Subscribe

Insufficient free space for thin provisioning

Good morning,

I've installed a new OpenStack single host but I'm having some troubles on Cinder module. I'm getting the following warning message, so any instance using a big volume fails when launching.

 

2018-02-28 17:30:33.463 12381 WARNING cinder.scheduler.filters.capacity_filter [req-bc96b3c4-820d-4851-8d54-800971a61ce6 2097652168834963b3374aa5edcd8a1d 35d9b1a4b0ee493c8935a5ca09247dc0 - default default] Insufficient free space for thin provisioning. The ratio of provisioned capacity over total capacity 1.02 has exceeded the maximum over subscription ratio 1.00

 

I think that the solution should be to change the maximum over subscription value, however when I change the cinder.conf file, the OpenStack loose the connectivity with Cinder module.

Thanks.

Re: Insufficient free space for thin provisioning

What backend are you using for your Cinder storage?

Re: Insufficient free space for thin provisioning

I'm using the default configuration. I didn't change any parameters.

Re: Insufficient free space for thin provisioning

In that case you are using LVM as your Cinder backend, not NetApp storage of any kind.  Yes you can increase your ratio, but restarting the Cinder service to read it does interupt service.

Re: Insufficient free space for thin provisioning

Is there a command to change the ratio value? Maybe I'm doing something wrong when I do it manually using the config file. Thanks

Re: Insufficient free space for thin provisioning

We normally just answer questions for OpenStack around NetApp products, but

 

Its all in the cinder.conf file.  You need to make sure your lvm_type flag is set to thin or you can't oversubscribe at all.  Then just update your max_over_subscription_ration to 2.0 or 3.0 save and restart all cinder services.