Active IQ Unified Manager Discussions

[7-mode] Per domain cpu utilization missing on CLI/ZAPI in OCUM but available in NMC

marcinlub

Hello,

I'm trying to get performance counters using ZAPI from perl (in order to export graphs to XLSX file). 

I can get regular performance counters (like FCP average latency) but I'm getting problems with domain busy. 

 

 

 

Counter "processor:domain_busy" is invalid.

 

 

When I check on CLI on the OCUM it also doesn't show the domains.

 

C:\Users\XP96SMPlsa>dfm perf counter list NTAP-20A-OW:processor:*:*:*
Object    Instance                 Counter                  Label1    Label2    Unit      Priv
-------   ---------                --------                 -------   -------   -----     -----
processor processor3               processor_busy                               percent   basic
processor processor3               processor_elapsed_time                       none      basic
processor processor3               sk_switches                                  per_sec   basic
processor processor1               processor_busy                               percent   basic
processor processor1               processor_elapsed_time                       none      basic
processor processor1               sk_switches                                  per_sec   basic
processor processor2               processor_busy                               percent   basic
processor processor2               processor_elapsed_time                       none      basic
processor processor2               sk_switches                                  per_sec   basic
processor processor0               processor_busy                               percent   basic
processor processor0               processor_elapsed_time                       none      basic
processor processor0               sk_switches                                  per_sec   basic

But when I use NMC to connect to OCUM in Performance Advisor fot the same object NTAP-20A-OW I can see the processor per domain utilization. 

 

 

I have previously used the same perl code to connect to older DFM (4.2) and it worked. What do I have to do to get the domain counters over ZAPI/CLI ?

 

 

 

0 REPLIES 0
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

Public