Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

All Functions not exported with Workflow?

stjerna

Hi,

I've created a couple of workflows using some custom functions. One of the functions refuses to be exported together with a workflow.

Have to create a separate export for that particular function.

WFA version 2.1.0.70.32.

Any ideas to why this happens?

Thanks in advance,

Erik Stjerna

1 ACCEPTED SOLUTION

adaikkap

Hi Erik,

           I circled backed the workflow that you sent me, to the Engg team and this has been attributed to a known issue of bug # 740209.

Pls keep an eye on the same, and open a customer case and add it to the bug, if this has any customer associated.

BTW this is happens in case the custom function (only) is referenced from the return parameter, And this does NOT happen for canned functions even if referenced in the return parameter.

The current suggested workaround are the following, which you have already done.

1.     Export the function separately from workflow. Import both of them.

2.     Write the function again manually or copy/paste.

Regards

adai

Message was edited by: Adaikkappan Arumugam

View solution in original post

10 REPLIES 10

adaikkap

Hi Erik,

     What is the browser you used for exporting ?

Also can you share both the dar file so that we can figure out whats happening ?

Regards

adai

stjerna

Hi Adai,

I am using Firefox v.26 on a Mac.

The Workflows and Functions are on it's way to you via email.

I was under the impression that all custom functions would be exported with all workflows even the workflows did not depend on them?

Thanks,

Erik

dhruvd

Hi Erik,

In 2.0.1, whenever a workflow was exported, all the custom functions were exported. However, in 2.1, this behavior was changed to export only those functions that are referred from within the workflow.

Hence,  now whenever a workflow is exported, only the used functions are exported.

Example: A function will get exported if it is used in defining a value for an attribute within the workflow.

Regards,

Dhruv

stjerna

OK, thanks,

That sounds like a better solution but then there is still an issue in the WFA version I'm running since one of my workflow uses 2 functions and when exported only one of them was included.

I noticed this when I decided to start from scratch with my WFA install. I exported my 3 workflows, reinstalled WFA, imported the workflows and 2 functions were missing. I rewrote them because they were pretty simple and I had done a backup before reinstall but still...

--erik

adaikkap

Hi Erik,

           I circled backed the workflow that you sent me, to the Engg team and this has been attributed to a known issue of bug # 740209.

Pls keep an eye on the same, and open a customer case and add it to the bug, if this has any customer associated.

BTW this is happens in case the custom function (only) is referenced from the return parameter, And this does NOT happen for canned functions even if referenced in the return parameter.

The current suggested workaround are the following, which you have already done.

1.     Export the function separately from workflow. Import both of them.

2.     Write the function again manually or copy/paste.

Regards

adai

Message was edited by: Adaikkappan Arumugam

View solution in original post

mgoddard

Thanks Adai!

I've also seen this bug before, and resolved it by using export-all instead. We also use a subversion repository to track changes and store dar contents which gives diff/version/revert capabilities.

Let me know if I should raise a customer case to ensure it gets a better resolution priority.

M.

adaikkap

Hi Mike,

     Pls add open a case for the same and add it to this bug. BTW could you explain a little bit more on the export-all ?

Hope you are aware of how to open a case against WFA, if not here is the procedure for the same.

Valid controller serial number to open case.

ASUP from WFA (manual generation) and the WFA System ID.

Regards

adai

mgoddard

Hey Adai,

By export-all I mean, I use the "Administration -> Export All" option, and make sure the WFA instance I'm working with, only has the components I want in it where possible.

Since a .dar file is just a .zip file full of .xml documents, it's pretty easy to combine or remove things you don't want, or track them with a source control system.

Michael.

abhit

Hi Erik:

Can you please Open a Case through the NetApp Support Site (https://support.netapp.com) or by calling one of the

NetApp support numbers listed under Contact Tech Support.  Please refer to the Communities thread when

opening a case by adding a link to the thread. This will help us to get this issue rolled into a maintainance

release.

 


Regards

Abhi

stjerna

Thanks Adai!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public