The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to register at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Cannot invoke method tokenize() on null object

smorganarrisi

Been using Balance to monitor for over a year and just recently started getting this error a few of our nodes.  This does not happen on each node, only a few.  Some work just fine.  We have rebooted the balance appliance, deleted and rediscovered the filers with the same result.  These filers did work at one time, but have since stopped.  We are only having issues trying to collect stats.  The discovery of the filers is fine.  We are running 4.1.0.2.9


7 REPLIES 7

GMSWEET716

What version of OnTap are you running?  We just started getting this after upgrading to 8.1.3P3 and I've got a case with NetApp open for a resolution.  We are running Balance 4.1.0.2 build 9 as well.

smorganarrisi

One HA pair is 8.1.3P3, but the other range from 8.1.1 to 8.1.3

GMSWEET716

I'll post back once I hear from NetApp with a solution.  Just for reference, here's how we arrived at the problem.

  • 2 HA pairs both running 8.1.2P3 with Balance 4.1.0.1 build 26
  • Upgraded both HA pairs to 8.1.3P3 to solve an unrelated issue
  • A couple of days later I went to check on a performance item and found that stats had not collected since the OnTap Upgrade
  • I rebooted the Balance appliance (no change) followed by the update to Balance 4.1.0.2 build 9 (no change)
  • Case 2004689026 opened with NetApp

Is it just your 8.1.3P3 nodes that stopped responding?  That may be the common component.

smorganarrisi

Unfortunately it was not just the P3 node.  I thought that was the common component, but specifically...

8.1.3P3

8.1.3

8.1.3P1

Again we have other nodes at 8.1.3 and 8.1.3P1 and they work.  None of the 8.1.3P3 work though.

GMSWEET716

Here's what I heard from NetApp:

There is a known issue with the changes in how ONTAP 8.1.3x handles performance queries.  The relevant BURT is #738776 and the remedy is to upgrade OCB to the current release 4.1.1.1.  Unfortunately, I do not have enough familiarity with OCB to quantify why the one partner is still reporting performance data.  I do know that the change to ONTAP made it load sensitive- if the response to OCB requires too much resources (memory) ONTAP will send a different response.  OCB 4.1.0.2 is not prepared for this behavior whereas the code in 4.1.1.1 is modified to accommodate.

To obtain the latest Balance version, 4.1.1.1, please log into the Support website and navigate to the software downloads

https://support.netapp.com/NOW/download/software/oncommand_ib/4.1.1.1/download.shtml

Please review the notes on this page prior to downloading and installing OCB. 

The OnCommand Balance Installation and Configuration Guide and the Release Notes are also accessible via this page. 

I'm going to upgrade Balance this morning and see what happens; I'll post back my results.

smorganarrisi

I will give it a shot, was hoping to delay the upgrade because of the license changes in 4.1.1.1.

Thanks for the responses.

GMSWEET716

I just finished the upgrade and 4.1.1.1 seems to have solved the problem for me.  I'm now getting statistics on all of our filers again.  I hope the licensing change doesn't affect you too badly.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public