Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Error message while acquiring VC datasource

bachman

Greetings,

For the past 5 days, we've been seeing this error logged when WFA tries to acquire the Virtual Center datasource:

Cannot bind argument to parameter 'Disks' because it is null.

Has any one seen this and knows what the problem is?

Phil

5 REPLIES 5

bachman

Here's a screenshot.

sinhaa

Hi Phil,

     This is a known issue in VC Data Source acquisition and its planned to be fixed in the future WFA releases. The cause for this failed acquisition is that one or more of your Virtual machines don't have any disks. By default at least 1 disk is always created at the time of creating a VM. However a user can later edit the VM configuration and even delete this disk. But this VM is now of no use.

Till the solution is available in the WFA future builds, I can suggest a workaround. Delete those VMs which don't have any disks or add some disks to those. Then try WFA VC Datasource acquisition, it should work fine.

Let me know it you need any more help.

-Abhishek

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

sinhaa

Phil,

     The fix will be available in the next WFA release which is expected soon.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

kleemola

I've found a similar bug with the vcenter datasource in WFA 2.0.1.  If a Datacenter object has no children, the acquisition errors out with "You cannot call a method on a null-valued expression".  Removing the empty datacenter seems to be one workaround.

sinhaa

Keemola,

            This is a known issue, but I'm not sure if its in the road-map to fix this issue in the near future. Your workaround is correct.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public