The community is undergoing maintenance and is in Read-Only mode. Click to learn more.

Active IQ Unified Manager Discussions

Getting error when defining export rules in a table for WFA workflow

Martin_Sandell

Hello all smart people.

I'm trying to create a workflow to create a volume with NFS export.

But I'm stuck on the export rule part, the software isn't accepting my variable for clientmatch, ro, rw and superuser that Iam supposed to get from the export rule table.

 

It feel's like I have looked everywhere and it all looks like the default "create a clustered data ontap nfs volume", but it's not working.

 

Under here is how it's configured and what defenition I have in the workflow command:

 

The user input tab:

User inputs

 

The workflow command defenitions:

Workflow command

 

getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,1)
getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,2)
getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,3)
getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,4)

 

This is how I test it via the preview function:

Workflow_preview.png

 

And the result is this error:

 

Failed to resolve expression 'getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,1)'
Location: 'Create export rule' command > 'Export_Rule' tab > 'Create_Export_Rule' variable > 'clientmatch' property

 

I'd be glad for all help to get past this issue!

 

Regards Martin Sandell

5 REPLIES 5

joele

Martin,

 

Would you be able to export that workflow and upload it here (or send me a message and we can coordinate offline) ?  I'd be happy to take a look at the workflow and it's a little easier to do in WFA's editor.

 

Joel

sp_1008

I am getting the same error when defining export rules in a table for WFA workflow.

Can you please share correct powershell  code for  defining export rules in a table for WFA workflow?

joele

Powershell code or the MVEL syntax in the workflow editor?  

 

In any case - if you want to share what you have so far (publically or privately, message me if the latter) I can help take a look.  Let me know!

 

Joel

sp_1008

I am getting  below error when try to exeucre the WF . 

Failed to resolve expression 'getValueAt2D($ExportRuleSpecification,ExportRuleLoopIndex,1)'
Location: 'Create export rule' command > 'Export_Rule' tab > 'export_rule' variable > 'clientmatch' property

 

 

joele

I worked with sp_1008 offline on this one.  The error:

 

"Failed to resolve expression 'getValueAt2D($ExportRuleSpecification,ExportRuleLoopIndex,1)'"

 

Was occuring as there was no row repetition setup, so the row index variable ‘ExportRuleLoopIndex’ didn't exist anywhere, hence WFA failing to resolve the expression.

 

The way to fix this particular issue is to create a new row for the create export rule command, have the row repeat based on the number of entries in your variable $ExportRuleSpecification user input, and then the syntax will work.

 

NetApp certified workflow ‘Create a Clustered Data ONTAP NFS Volume’ should have an example to work from – it creates the export policy on first row, creates export rules on row two and is repeated as necessary, and creates the volume on row 3.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public