The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to register at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Harvest Snappmirror Replications dashboard datasource failed

PhilipStilling

Hello Community,

 

actually i am running a Harvest with the following versions:

 

NAbox 2.5 (2018-12-16).
NMSDK 9.6.
Harvest 1.6.

 

I want to use the Snapmirror Replications Dashboard, but the Grafana can't find the Datasource:

Datasource named ${DS_GRAPHITE} was not found

 

Does anybody have a clue how to solve this issue? I can't find the mentioned DataSource in Grphite as well.

 

Greetings Philip

16 REPLIES 16

yannb

@vachagan_gratian 🙂

 

Yes that's a known bug, the workaround is to edit the JSON for the dashboard, in Grafana, and replace ${DS_GRAPHITE} by "default", I'm writing this from memory.

 

Be aware that in itself, this is not enough, you also need to enable the snapmirror plugin in harvest configuration (it's provided in standard distribution)

 

[EDIT]

Snapmirror extension is available in the extensions directory and enabled in the "template" directive of the config file, see IAG chapter 12

 

[my_controller]
hostname = 10.77.77.4
group = DEV
username = my_username
password = my_password
template = default, extensions.conf

 

PhilipStilling

@yannb  Thank you for your reply.
@yannb wrote:

Be aware that in itself, this is not enough, you also need to enable the snapmirror plugin in harvest configuration (it's provided in standard distribution)


Sorry maybe i have tomatos on my eyes but i can't find the mentioned plugin. Could you please send me a link to the mentioned document?

 

Greetings Philip

yannb

If you're using 1.6, it should be described in the Installation and Admin guide, let me know if you can't find it I'll dig that out for you.

MartINC

There's a typo in the doc, you must write "extension" without an "s";

 

template = default,extension.conf

 

jfc916

did you get this error?

 

[2019-09-20 12:26:00,736] [ERROR] [load_prereqs] Failed to import NaServer: No module named NaServer

 

cant figure out a solution or this. 

MartINC

yes I do have the same error. Another user reported the issue in the following discution:

 

https://community.netapp.com/t5/Data-Infrastructure-Management-Software-Discussions/NetApp-Harvest-1-6-is-out/td-p/150671

 

I'm still waiting for a solution.

jfc916

thanks, guess i will wait in line. 

jfc916

so i got beyond this issue, i downloaded sdk96 and copied the files

DfmErrno.py
NaElement.py
NaElement.pyc
NaErrno.py
NaServer.py
NaServer.pyc

 to the lib dir

 

but know i get the following error. 

 

[2019-10-17 14:03:01,160] [ERROR] [poll_snapmirrors] ZAPI request failed: Insufficient privileges: user 'netapp-harvest' does not have read access to this resource

MartINC

.py ? Oh interessting.  I only have .pm files in that folder (/opt/netapp-harvest/lib).

 

Unziping the SDK extract .pm files not .py, is that right ?.  Example from doc:

 

unzip -j netapp-manageability-sdk-9.6.zip netapp-manageability-sdk-9.6/lib/perl/NetApp/* -d /opt/netapp-harvest/lib
Archive: netapp-manageability-sdk-9.6.zip
inflating: /opt/netapp-harvest/lib/DfmErrno.pm
inflating: /opt/netapp-harvest/lib/NaElement.pm
inflating: /opt/netapp-harvest/lib/NaErrno.pm
inflating: /opt/netapp-harvest/lib/NaServer.pm

yannb

Yes that part is a bit confusing. You need the perl sdk for harvest itself, but the extension being written in python, you also need the python SDK, which, this time, must be present in the python/ directory without the NetApp parent directory. 

MartINC

I'm also getting farther after uploading the .py files from the SDK to the /lib folder.

 

I'm using auth_type = ssl_cert.  Data collection is working perfectly but the snapmirror extension complains about ssl certificate:

 

[ERROR] [poll_snapmirrors] ZAPI request failed: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:618)

 

 

vachagan_gratian

Hi @MartINC, the snapmirror extension only supports authentication by password, but I think I can adapt it to support certificate authentication as well. Let me know if you need that.

MartINC

Hi Gratian,

 

Yes I believe that would be a nice feature to add for security purpose.

 

Thanks!

 

Martin.

yannb

Extensions in Harvest are quite new, and are provided as examples, with the current distribution, meaning they are to be taken "as-is" and might need some improvement (which will happen over time I'm sure).

 

The only supported authentication method is LOGIN, you can certainly implement certificate authentication in the code, and feel free to share your changes here 🙂

jfc916

yeah, i just copied the py files to the /opt/netapp-harvest/lib and the error went away, the next error I got was an authorization error, so i elevated the harvest user to admin, and the files are gettting generated. It seems to be working. 

johannes_mitterer

@jfc916 wrote:

yeah, i just copied the py files to the /opt/netapp-harvest/lib and the error went away, the next error I got was an authorization error, so i elevated the harvest user to admin, and the files are gettting generated. It seems to be working. 


You don't have to give the harvest user full admin permissions. It is just necessary to give access to the  "snapmirror show":

 

security login role create -role netapp-harvest-role -access readonly -cmddirname "snapmirror show"

 

@vachagan_gratian: maybe this should be added to the "Harvest Administration Guide" Topic 5.2.2

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public