Active IQ Unified Manager Discussions

Harvest for ONTAP 9.4

vladimirzhigulin

Anyone knows when support for ONTAP 9.4 is going to appear in Harvest? 

1 ACCEPTED SOLUTION

gmey
we do get an increasing number of questions when we will have a Harvest version 
available for ONTAP 9.4. As an update for you, we are working to get Harvest 1.4.1
ready within the next weeks. Starting with ONTAP 9.5 we will align the Harvest versions
to ONTAP - so Harvest 1.5 will be the one we will publish fall this year.
 
For the time being you can update the template for ONTAP 9.4 with your current Harvest 1.4
config:
 
# /opt/netapp-harvest/netapp-manager -status
 
# /opt/netapp-harvest/netapp-manager -stop -poller <cluster 9.4 #1>
# /opt/netapp-harvest/netapp-manager -stop -poller <cluster 9.4 #2>
...
 
#  cp /opt/netapp-harvest/template/default/cdot-9.3.0.conf /opt/netapp-harvest/template/default/cdot-9.4.0.conf
 
# /opt/netapp-harvest/netapp-manager -start -poller <cluster 9.4 #1>
# /opt/netapp-harvest/netapp-manager -start -poller <cluster 9.4 #2>
 
# /opt/netapp-harvest/netapp-manager -status

View solution in original post

13 REPLIES 13

Hexagon

We did this as part of our standard upgrade process, but we're seeing very strange readings for netapp.perf.$Group.$Cluster.node.*.vol_summary.avg_latency after the upgrade. Before the upgrade, we were seeing latencies of ~0 to ~20ms or thereabouts, but after the upgrade we're seeing latencies reported in the minutes. At first I thought this was due to a change in magnitude of some of the counters, but manually telling grafana that the metric was in e.g. µs still shows data that doesn't look right (800ms latency).

 

Has the meaning of this counter changed on the NetApp side? Is there a way for us to reinterpret this data on the Harvest/Grafana side?

vachagan_gratian

Hi Hexagon,

 

Thanks a lot for the info. This is an issue that we are trying to address right now, but we are still looking for the exact causes.

 

Can you help us with a bit more details?

 

- Does this happen all the time or only occasionally?

- Did you look in the logs of Harvest, any warnings? (If so, can you copy-paste them?)

- What ONTAP system do you have? How many nodes in your Cluster?

 

Thanks in advance!

Vachagan

gmey
we do get an increasing number of questions when we will have a Harvest version 
available for ONTAP 9.4. As an update for you, we are working to get Harvest 1.4.1
ready within the next weeks. Starting with ONTAP 9.5 we will align the Harvest versions
to ONTAP - so Harvest 1.5 will be the one we will publish fall this year.
 
For the time being you can update the template for ONTAP 9.4 with your current Harvest 1.4
config:
 
# /opt/netapp-harvest/netapp-manager -status
 
# /opt/netapp-harvest/netapp-manager -stop -poller <cluster 9.4 #1>
# /opt/netapp-harvest/netapp-manager -stop -poller <cluster 9.4 #2>
...
 
#  cp /opt/netapp-harvest/template/default/cdot-9.3.0.conf /opt/netapp-harvest/template/default/cdot-9.4.0.conf
 
# /opt/netapp-harvest/netapp-manager -start -poller <cluster 9.4 #1>
# /opt/netapp-harvest/netapp-manager -start -poller <cluster 9.4 #2>
 
# /opt/netapp-harvest/netapp-manager -status

View solution in original post

SrikanthReddy

any approx date for next release or keep checking forums for update announcement 

thanks 

 

If everything goes as planned, you can download 1.4.1 this week or next week. We will send out an announcement once it is available 🙂

moep

I also see vol_summary.avg_latency graphs go through the roof since updating to 9.4P2. I see values up to 8 seconds (!) instead of milliseconds. The other latency counters look normal So far it is only on our snapmirror target.

rezkmekhael

I did the following

  • upgrade to  harvest 1.4.1
  • copy   cdot-9.3.0.conf to  cdot-9.4.0.conf
  • reboot harvest server 

still see vol_summary.avg_latency graphs go through the roof since updating to 9.4P2  - any more input 

 

root@:~# apt list --installed|grep netapp

WARNING: apt does not have a stable CLI interface yet. Use with caution in scripts.

netapp-harvest/now 1.4.1 all [installed,local]

 

bkamil

Maybe it's something wrong with the counter itself, not Harvest?


One could verify with "statistics show-periodic" what are the actual values reported by ONTAP.  If those are incorrect, the fix should be implemented in ONTAP, not Harvest. It might be possible to implement a WA in Harvest for the time being, though.

I don't have any 9.4 around so cannot check myself.

FabianGlaser

Same here the Cluster --> Latency Dashboard is reporting more than one minute latency. OnTap 9.4P2 and latest Harvest and Grafana.

 

 

rezkmekhael

any update on this bug?

Hi, yes we have some updates! See my post here.

Lplatform

another one having this issue with vol_summary.avg_latency, AFF220 9.4P2 version.

vladimirzhigulin

Thanks, it's an acceptible workaround!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public