Active IQ Unified Manager Discussions

Issue with wfa_ocsetup.exe


I'm having trouble with wfa_ocsetup.exe on Oncommand 5.1 Cluster Mode running on Windows 2008R2.

The executable defaults the java location to C:\Program Files\NetApp\DataFabric Manager\DFM\java which isnt the correct path for my OC install folder. The correct path is D:\Program Files\NetApp\DataFabric Manager\DFM\java.

If i browse to the correct path wfa_ocsetup lets me continue, anything else prompts me that JRE 1.6 is required. I supply bespoke username/password and when i hit next i see the following. It seems it doesn't like the space in the path and It wont allow me to put it in quotes.

If I hit next it appears to complete but I get invalid login when i try to connect WFA to Oncommand. A dfm database user list doesn't show the wfa user. I'm not sure if its supposed to if the script is successful.

I'm wondering if this is me being stupid or if the exe has issues with non default paths.

Any help or suggestions would be appreciated.



Re: Issue with wfa_ocsetup.exe


It seems the wfa_ocsetup.exe is getting choked up on the space in the path name.  This looks like a bug to me.  Until it's fixed, a couple of things you can try...

1) After you browse to your java dir and choose it, see if you can type double-quotes around the path. 

2) Get the 8dot3 (short) name for any directory in the path with a space in it and use that instead.

For example,

  • Open a command prompt (Start->run->cmd). 
  • Change to the 😧 drive.  (D:) 
  • If not already in D:\, change directories to D:\ (cd \).
  • Use the /x option on 'dir' command to get the 8dot3 name of the "Program Files" directory. (dir /x)
  • Make note of the 8dot3 name. (copy to notepad or something)
  • cd into program files (cd "program files")
  • cd into NetApp (cd netapp)
  • Do dir /x again.
  • Make note of 8dot3 name for "DataFabric Manager".
  • When running wfa_ocsetup.exe, after choosing the path to java, replace "Program Files" with the 8dot3 name. (Probably PROGRA~1) and replace "DataFabric Manager" with the 8dot3 name (probably DATAFA~1).

If it runs successfully, you should see something like the following:

Hope this helps,


Re: Issue with wfa_ocsetup.exe


Thanks Dave,

I've tried to put the path in quotes and it throws an error stating the path needs to be in the form C:\ or \\server\share. Quotes around either yeild the error.

8dot3 name creation is disabled by default on our servers.

What i dont understand is that the default path for Oncommand install is C:\program files\ so why doesnt this fail for everyone?  All i'm doing is replacing C:\ with D:\.

Re: Issue with wfa_ocsetup.exe


Are you sure you're using the latest version of wfa_ocsetup.exe?  This was supposed to be fixed in the 1.1.1 version.  What build of WFA do you have?  Can you download the wfa_ocsetup.exe file from the WFA server again, just to make sure you've got the latest and greatest?  It can be downloaded from the WFA Server onto the OCUM server using a web browser on OCUM server and pointing it to:




Re: Issue with wfa_ocsetup.exe


Hi Neil,

The installer uses the "cmd.exe" under your Windows system32 root (usually under "C:\Windows\System32").

We have tested with spaces and non default OC paths like "C:\Program Files\Java\jre6".

Looking at the error I suspect something is wrong with your PATH environment variable.

Did you happen to modify your PATH variable recently ?

If so can you please check if you had forgotten or added any extra characters before/after "C:\Windows\System32" ?

This should end with a semicolon (;), if that is missing, can you please add the missing semicolon and try again.


Re: Issue with wfa_ocsetup.exe


Thanks for the replies guys.

Dave, the version is 2.0. I downloaded and installed WFA right before hitting this issue. I've copeid a new version from the WFA server with the same result.

Sandeep, as far as I know there's been no manual configuration of the path variable before I moved C:\windows\system32 to the front for clarity, its configured as follows:

PATH=C:\Windows\system32;D:\Program Files\NetApp\DataFabric Manager\DFM\java\bin

;D:\Program Files\NetApp\DataFabric Manager\DFM\bin;D:\Program Files\NetApp\Data

Fabric Manager\Sybase\ASA\win32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\S

ystem32\WindowsPowerShell\v1.0\;C:\Program Files\Microsoft Network Monitor 3\;C:

\Program Files\NetApp\SnapDrive\;C:\Program Files\NetApp\SnapDrive\

As a matter of interest if you're using the cmd.exe then why not allow double quotes around the path in the gui?



Re: Issue with wfa_ocsetup.exe



Sent you a couple of offline community messages in order to look at this more closely.

Did you manage to get around this?

If not, Kindly reach out to me or Sandeep (sputrevu community user above).



Re: Issue with wfa_ocsetup.exe



I'm working on a fresh WFA 2.0.1 installation where DFM is installed at E:\Program Files\... and wfa_ocsetup.exe is reporting

'E:\Program' is not recognized as an internal or external command, operable program or batch file.

8.3 naming is disabled and adding quotes around the path results in an error ('you must enter a full path with drive letter...' or 'Folder names cannot contain the following characeters...', depending on where I put the quotes).

Could you share the workaround if one exists or a patched wfa_ocsetup.exe?


Re: Issue with wfa_ocsetup.exe


Some how the space in your path is not recognized in the path to Java. I can give workaround here.

1. copy the folder NetApp\DataFabric Manager\DFM\java to some location E:\

2. Run the installer wfa_ocsetup.exe and browse this java path when prompted so that it becomes like E:\java

3. Proceed with username/password.

4. Finish the installation.

5. You may delete this E:\java if you wish.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

Re: Issue with wfa_ocsetup.exe


Hi Sinhaa,

thanks for the tip. I had tried copying that folder to C:\javatemp\java without success (it reported that it could find a valid java installation - I must have done something else wrong...), but the second time, moving it to E:\java, worked like a charm!



Earn Rewards for Your Review!
GPI Review Banner
All Community Forums