Active IQ Unified Manager Discussions

Missing volume?

I'm checking the amount of available space on our NetApp. I have experience of working on Dell EqualLogic SANs and PowerVaults, iSCSI and Direct Attached. But I am not familiar with NetApp, and I've seen something today that I don't understand, can you help?
We're using Xencenter with some connected VM hosts.
On the NetApp interface:
One of the main Aggregates (there are 4) has 3 volumes in it. One of these is 1TB in size and has 0% space utilisation. I don't see this lun being presented to the XenCenter, or anywhere else on the NetApp OnCommand System Manager. Is it reserved for system use? Or just not set up? How can I tell? How can I make it available for VM storage?
Thanks in advance!




We will need some info to help you out.


If I may assume, you haven't worked with NetApp storage and at present there is no 'storage/lun' being presented to xencenter ?  Are you familiar with NetApp system Manager GUI? Again depending upon which Ontap you are using the  GUI menu will be different.



1) Ontap version ?

2) How do you intend (Protocol) to present the LUN : FC/iSCSI [Is the protocol service up]

3) Have you created the LUN inside the Volume?

4) Have you created igroup : [contains Host's Initiator] ?

5) Have you mapped the LUN to igroup?

6) Have you discovered the LUN from the host (xencenter) ? I haven't worked with xencenter, but the basic logic remains same.


How to configure LUNs and igroups for Citrix XenServer








The problem I see is that there are 8 volumes in the NetApp, 5 on one aggregate, 3 on another. There are 6 volumes presented and used in XenCenter for storage. So there are two volumes missing from XenCenter. One of the ones I can't see has the word "root" in its name, and is only 1GB in size, so I wouldn't expect that to be showing. The other one I can't see in XenCenter is showing in the NetApp OnCommand System Manager as 1 TB and unused, so I am puzzled as to why it's not in XenCenter like the others.


I guess it just hasn't been added, for some reason. I have inherited this system. I now know that we have support, so I'll ask them. Meanwhile it's been helpful just to "talk it out".


To answer your questions:

1. I don't know, what is OnTap?!

2. FC, same as the others. Yes the service is up. We also have an older NetApp connected which uses iSCSI, that's working OK.

3. I believe there is a LUN inside the volume.

4 & 5, now you've lost me, I am not familiar with igroup, and can't see that in the NetApp OnCommand System Manager.

6. No, that's the problem.


Thanks for your help, and your helpful links. The first link is broken, by the way.


Kind regards


Ontap is the 'storage operating system' running on NetApp FAS/AFF Arrays.  Could you tell me what NetApp Model you have ?


1) Are you able to ssh to your netapp?

2) Do you use 'root' or 'admin' to login to  'OnCommand System Manager' ? or via ssh?






It's ONTAP version 9.0.

There are 2 x nodes, both are model FAS2552. One is older than the other and doesn't get used in production.

Yes, I can SSH to the same IP address as the NetApp OnCommand System Manager, and log in with the same credentials. Not root or admin, so maybe I don't have root or admin privileges.