Active IQ Unified Manager Discussions

NetApp-harvest Lun performance graph issue

hashiya1112

I use netapp-harvest 1.2.2


cDOT Version 8.2P3 collected by harvest

When I looked at the graph of "NetApp Detail: LUN", I realized that the value was wrong.

What can I fix?

1 REPLY 1

madden

Hi @hashiya1112

 

Reported IO spikes like these are likely the result of the ONTAP API returning incorrect data to Harvest, which it in turn passes to Graphite.  Sometimes the root cause is an ONTAP bug, and since you are running a quite old release (8.2) upgrading ONTAP might resolve.  I also see you are using an older version of Harvest (1.2.2) so upgrading it is also a good idea but I doubt updating only Harvest will solve the issue.

 

I have a theory for what causes this issue and would like to try a potential workaround for it.  If you are interested to trial this with me please send a private message.

 

Cheers,
Chris Madden

Solution Architect - 3rd Platform - Systems Engineering NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public