The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Netapp Harvest/NA Box not polling capacity svm

Zerolimit

NAbox 2.5.1b (2019-02-22) Visit Web Page

Debian GNU/Linux 8 (jessie) (8.11) Visit Web Page

NetApp SDK v9.5 installed Visit Web Page (NetApp Login Required)
Harvest v1.4.2 installed Visit Web Page (NetApp Login Required)
Grafana v5.4.3 installed Visit Web Page
Graphite v1.2.0 installed Visit Web Page

Elasticsearch 5.6.15 installed. Visit Web Page
Logstash 1:5.6.15-1 installed. Visit Web Page

API Key : Reveal | Create a new key

 

I upgraded from 2.4.2 and i have tried fresh install of 2.5.1b and im unable to poll netapp capacity metrics for svm.  Has anyone run into this issue.

10 REPLIES 10

RajeshPanda

@Zerolimit  following up to see if you got a chance to look into the recommndeation provided , Lte me know if you are still looking for help.

amozen

I have exactly the same error. Can someone provide info for the fix. Communication between NAbox and OCUM via port 443 is working. Increasing timeout to 180 seconds didn't help.

yannb

You probably didn't configure OCUM poller. For capacity information, you need to have OCUM installed and configure it in NAbox.

 

If you just configure your cluster you will only get performance metrics.

Zerolimit

OCUM is configured and running. In the logs i see this  the errors below. 

[2019-03-14 18:46:03] [WARNING] [volume] update failed with reason: Timeout. Could not read API response.
[2019-03-14 18:46:03] [WARNING] [volume] data-list update failed.

yannb

Interesting.

 

Are you sure that NAbox can communicate with OCUM over port 443 ?

 

If the answer is yes, any time I had a similar issue it was solved by an OCUM reboot...

Zerolimit

Once in a while i would have to restart the OCUM services. I thought it was an upgrade issue when we upgrade NAbox from 2.4 to 2.5x but that was not the case.  I also setup an entirely new instance on 2.5.1b and it still has the same issues.  It is communicating over 443 to our OUCM instance it as performance data is being pulled in.  

yannb

So you’re saying restarting OCUM fixes the issue ?

Zerolimit

in the past that used to work.

Hi Zerolimit,

It seems like Harvest is getting late responses from your OCUM system. What you can do is change the default timeout parameter in Harvest and seek help from support for the OCUM API response time.

 

You can manually edit netapp-worker to change the default timeout setting. This file is usually located in the folder /opt/netapp-harvest/. You can use vim or nano to edit the file.

 

On line 612 you should see this:

        $out = $s->set_timeout('60');

Change 60 to 180, save and restart Harvest. If it doesn't help, try again by setting it to 300.

vachagan_gratian

Hi Zerolimit,

 

Did you look in your OCUM poller logs? Any warnings or errors there?

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public