Active IQ Unified Manager Discussions

OCUM (7.1RC1) root password


Hi guys,


my appliance crashed and is unable to boot.

I tried a few times but it always stops with "fsck died with exit status 4".


I need the root pw to run fsck manually.

My "admin" / "maintainance" password is NOT working as root password.


First respone from NetApp support was

"The root account is disabled by default in the UM 6.x virtual appliance, and the password for the root account is not known to NetApp Support."

Although I said 7.1RC1 but anyway.


I doubt nobody knows the root pw or at least how to enable and reset it.


Hopefully somebody here can help me out.






I fixed it by booting from a linux live OS iso and ran fsck there.

Still having the root pw would be easier.




With access to the console you could reset it yourself.


Did you ever find the default root or diag password for OCUM 7.x or at least how to set it or reset it?

I was trying to avoid having to reboot the vApp but it wouldn't be that big a deal if I have to in order to set the password.





The following works for OCUM 7.3 to get the root password for the OCUM VM appliance. I feel confident that Support won't appreciate you doing this on a production system, so YMMV, and all that.


You will need a Linux VM on the same ESX host that is running the OCUM appliance.


1) Shut down your OCUM VM and your Linux VM

2) Add the first virtual disk of your OCUM VM to the Linux VM (Incidentally, the first disk is the boot disk, the second disk is swap, the third disk is an LVM group for the database, and the fourth disk seems like a bare-bones rescue boot disk or something)

3) Boot your Linux VM off of its own boot disk.

4) Mount the OCUM disk (e.g. mkdir /ocum_disk ; mount /dev/sdb1 /ocum_disk)

5) Change root directories: chroot /ocum_disk

6) Unlock the root user: usermod -U root

7) Set root's password to whatever you want: passwd root

😎 Exit the chroot jail with CTRL-D or 'exit'

9) Unmount the OCUM volume: umount /ocum_disk

10) Shutdown the Linux VM: shutdown -h now

11) Remove the OCUM disk from the Linux VM configuration

12) Boot OCUM and login on the console as root with your new password.


Note that the SSHD configuration has root login disabled, so you won't be able to SSH as root into the OCUM server, but logging into the console is no problem.


It seems like the OCUM VM should ship with root enabled, because there are certain reasons (like some WFA Packs) that require adding/modifying files on the OCUM server.


Ok, so just had this same problem, needed to reset lost root p/w.


Found there is an easy option, but it does rely on access to system or VM console, and requires a reboot (which shouldn't generally be a problem).


So, reboot using either admin user menus, or reset system if necessary.

Watch system console, wait for Netapp "OnCommand Unified Manager" menu screen to come up, which has two options - "Standard mode (default)" and "Change maintenance user's password".

Use up or down arrow to make the boot pause on this screen.


You can press "e" for edit at this screen, just as if you were at the GRUB menu.


I happened to press e while I was selected on the change maintenence user's password option, and found you can change the "init=" part of the line from the password reset script, to "init=/bin/bash".

Then, type ctrl+x to boot using the new init setting, and you will boot into a root command prompt, where you can use normal passwd command to reset root password.

Then, just initiate a normal boot by exiting.


You may be able to do the same thing by editing the standard mode option also, I haven't tried that.

This was on a v9.4 system.



One post, but a good one while being stuck with ocum 🙂