Active IQ Unified Manager Discussions

OCUM upgrade fail 7.3P1 to 9.5P1 Java not found

mmorshed11

Hi All,

Wondering if anyone had the same issue, Tried to upgrade one of our virtual appliance OCUM 7.3P1 to 9.5P1  Notice Java didn't get install during the upgrade. Due to no Java OCIE doesn't start.

 

ul 16 12:41:08 cmsempocump01 ocie[1033]: Starting NetApp OnCommand Insight Essentials Server service: ocie/opt/netapp/essentials/jboss/bin/twiddle.sh: 46: exec: java: not found
Jul 16 12:41:18 cmsempocump01 ocie[1033]: /opt/netapp/essentials/jboss/bin/twiddle.sh: 46: exec: java: not found
Jul 16 12:41:28 cmsempocump01 ocie[1033]: /opt/netapp/essentials/jboss/bin/twiddle.sh: 46: exec: java: not found
Jul 16 12:41:38 cmsempocump01 ocie[1033]: /opt/netapp/essentials/jboss/bin/twiddle.sh: 46: exec: java: not found

After 60 mins  its timed out

Jul 16 13:41:06 cmsempocump01 systemd[1]: ocie.service: Start operation timed out. Terminating.
Jul 16 13:41:06 cmsempocump01 systemd[1]: ocie.service: Main process exited, code=killed, status=15/TERM
Jul 16 13:41:06 cmsempocump01 systemd[1]: Failed to start LSB: OnCommand Platform Server.
Jul 16 13:41:06 cmsempocump01 systemd[1]: ocie.service: Unit entered failed state.
Jul 16 13:41:06 cmsempocump01 systemd[1]: ocie.service: Failed with result 'timeout'.

 

 

1 ACCEPTED SOLUTION

mmorshed11

Thanks, @Ontapforrum  I found the issue, We were upgrading multiple OCUM instances. All of them was 7.3P1, unfortunately, one of them was 7.1P3 which is not supported to directly upgrade to 9.5 hence this error occurred. I have updated to 7.3p1 then upgraded to 9.5P1.

View solution in original post

2 REPLIES 2

Ontapforrum

Hi,

 

I am not 100% sure what caused it as we simply deployed a new instance instance of upgrade. May be those who upgraded can share their views.

 

In any case, there is a reference to 'java' in your error log, and looks like starting with Unified Manager 9.5, OpenJDK is provided in the Unified Manager installation package and installed automatically. Oracle Java is not supported starting with Unified Manager 9.5.  If it was a 'new install', it wouldn't have mattered, however b'cos it is upgrade, so I am guessing so.

 

Plausible cause: Directory /home/jboss was not created.

 

Create the /home/jboss directory, with the following steps:
https://kb.netapp.com/Advice_and_Troubleshooting/Data_Infrastructure_Management/OnCommand_Suite/Acquisition_server_does_not_stay_started_on_Oncommand_...

 


How to access ActiveIQ Unified Manager Virtual Machine (OVA) DIAG shell to create a directory:
https://kb.netapp.com/Advice_and_Troubleshooting/Data_Infrastructure_Management/Active_IQ_Unified_Manager/How_to_access_ActiveIQ_Unified_Manager_Virtu...

 

 

Thanks!

mmorshed11

Thanks, @Ontapforrum  I found the issue, We were upgrading multiple OCUM instances. All of them was 7.3P1, unfortunately, one of them was 7.1P3 which is not supported to directly upgrade to 9.5 hence this error occurred. I have updated to 7.3p1 then upgraded to 9.5P1.

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public