Active IQ Unified Manager Discussions

OnCommand Compatibility with Windows 8

DONALDVC58

I am curious about the schedule for providing OnCommand System Manager compatibility with Windows 8 and Windows Server 2012. I may well have missed something obvious, so please accept my apologies if this has been answered already.

Thank you,

donaldc

1 ACCEPTED SOLUTION

DONALDVC58

Just a quick update to note that the most recent version of System Manager (Version 2.0 (2.0.2)) now plays nicely with Windows 8 RTM and IE10.

Thank you to everyone for your comments.

donaldc

View solution in original post

23 REPLIES 23

james_cook

Just right click the top bar in ie10 and click menu bar.

On the menu bar click tools - compatability view settings

Add 127.0.0.1 or set all sites to run in compatablity settings.

ok

Works perfect after that

frank_iro

I'm getting a Java error with v2.0.2 on Windows 8 Pro x64. I have both Java 7 update9 32 & 64 bit versions installed. When I run it, I get the below error.

Have tried turning off the firewall & AV. Have tried "Run as Administrator". Have uninstalled & re-installed both Java & System Manager. No luck. Any ideas?

PROFESSORE79

Only thing I can tell you is that on my working domain machine:

- I use a regular domain account (no admin rights)

- we have Java 6 Update 37 x86 deployed (Java 7 has known authentication bugs with NTLM proxies so we have refrained from using it up to now)

Maybe you should/could try a Java 6 version but I don't know how System Manager picks a Java version ... maybe you would have to uninstall Java 7 version then only install Java 6 ... Just some ideas ...

As I understand Jetty seems to be a kind of HTTP server in Java that is used by System Manager. That's where the 127.0.0.1:<portnum> comes from, seems to create a local HTTP server on an arbitrary port then launches a web browser to connect there. Sounds like this Jetty server couldn't create such a listener port or "socket". One guess would have been that there is a conflicting port with other software but the ports are chosen arbitrarily from unprivileged ports, even above IANA registered range, so I'd say finding a free port between 49152 and 65535 shouldn't be such a problem ... So either it's a Java 7 runtime incompatibility or are you using IPv6 only/do you have IPv4 deactivated on your machine? (unlikely but ...)

Regards

frank_iro

Let me take out Java 7 and try Java 6. My PC isn't on any domain though, and I'm using IPv4.

amritad

Hi,

For 2.0.2 and 2.1 (our upcoming release) Java 7 is not supported. JAva 6 is supported. WE will be fixing this in the next rev after 2.1

Regards

Amrita

frank_iro

Thanks Markus & Amrita,

Took out java7 and put in the latest update of java6, and I am now up and running on Windows 8 Pro x64 on Firefox!

PROFESSORE79

Hi,

I'm running System Manager 2.0.2 on Windows 8 Pro x64. I had to activate "Compatibility View" (button next to the magnifying glass) and it works fine now. Had problems with SnapMirror properties before. I can add/edit volumes, qtrees, LUNs, SnapMirror relations, CIFS shares.

There is, however, a CIFS share bug when adding a share through System Manager when there is already a file/folder structure in the qtree containing umlauts/special characters - but I already had this problem on IE 9/Windows 7 before. Throws a ZAPI XML error which Firefox does not. But in Firefox the umlauts are shown with a wrong placeholder character looking like a question mark.

The NetApp communities and IE10 is another story, however 🙂 (no, this is no IE 6 ... ;-))

Regards, Markus

CEYHUN

I've installed 2.0.2 on Windows 8 X64. When I first started the application, "add" button did not work. So, I could not add controller.

Then, I changed the browser path to "C:\Program Files (x86)\Mozilla Firefox\firefox.exe". Now it works like a charm.

Tools > Options

Set Browser Path as  C:\Program Files (x86)\Mozilla Firefox\firefox.exe

Regards

Ceyhun

kelly7671

And when you Edit a Volume, while the Advanced tab can be selected, nothing shows up, just a blank tab.

kelly7671

Did a little more testing on Windows 8 today, and what I've found is that the "Add" or "Login" buttons do not work. To add your NetApp systems to System Manager, you have to use the "Discover" feature. You also cannot move the pop-up windows for features like Edit, Resize, Storage Efficiency, Snapshot Copies, etc... around, they are glued directly in the middle of the IE10 frame, regardless of the Compatability settings you choose.

So does it work, Yes, but with some features/options non-functional, but not non-functional like the Network Interfaces area, which was disabled by NetApp themselves due to a bug.

cori_grieb

Kelly-

How did you get it to even launch?  When I run it a black screen pops up briefly and then nothing happens.  Was there a new setting you found that made it work?  Did you have to install a different Java version?

Any suggestions would be well appreciated.

Thank you,

-Cori

kelly7671

I got it working on a fresh load of Windows 8, then going straight to www.Java.com with Internet Explorer and loading Java from the webpage. Once complete, I closed IE and installed System Manager. After that, I was able to just double-click the NetApp OnCommand System Manager icon from my Desktop, and presto.

cori_grieb

Thank you for the reply.  With that encouragement I tried again in vain, installing all versions of Java, the newest release of 7 and 6 in both x86 and x64 versions.  I will have to wait until NetApp fixes the underlying issue, glad it is working for some though.

Thanks,

-Cori

kelly7671

Also confirmed, it simply is not compatible with IE 10 on Windows 8. I would hope that NetApp is working on it since Windows 8 is now publicly available, and also since it's only compatible with Internet Explorer for some odd reason.

amritad

Hi

The SM 2.x line is not currently qualified with Windows 8. We are working on Windows 8 qualification with future releases. However we do have some customers who are using 2.0.2 with Windows 8.

Regards

Amrita

cori_grieb

I can also confirm that I have tried nearly every compatibility setting imaginable and have yet to get 2.02 working with Windows 8.  I am using the Pro RTM version.  If anyone has gotten this to work can you please provide instructions on how you were able to do so?  Also what version of Java you are running may be helpful as well.

I thank anyone in advance who can give me a lead on this.

-Cori

DONALDVC58

Just a quick update to note that the most recent version of System Manager (Version 2.0 (2.0.2)) now plays nicely with Windows 8 RTM and IE10.

Thank you to everyone for your comments.

donaldc

View solution in original post

pluecking

I've installed Version 2.0.2 but it's not working. I just see a dos box and a new java.exe Task but nothing happens. Can anyone help?

mjlthomas

*note this is hackish*

In my case also the browser was never opening but the Java process was spawning in the background. I wrote a powershell script to workaround the issue and happen to trying chrome and it worked.

$OnCommandPath = 'C:\Program Files\NetApp\OnCommand System Manager\';

Start-Process "$($OnCommandPath)SystemManager.exe"

while (!(Test-Path "$($OnCommandPath)SystemManagerLaunchURL.txt")){

Start-Sleep -s 1

}

Start-Process 'chrome.exe' (Get-Content "$($OnCommandPath)SystemManagerLaunchURL.txt")

I wrote this to file called Start-OnCommand.ps1 and then created a shortcut to call the file as follows:

powershell .\Start-OnCommand.ps1

/begin edit/

Make sure the shortcut start location is the same directory as your script file location. I actually edited the default OnCommand Shortcut and placed the file in C:\Program Files\NetApp\OnCommand System Manager\ which was my install path.

If you heavily customize your powershell environment you might add -noprofile to the execution command to speed it up as well.

I also run with elevated rights, though I think you can just change the directory security on C:\Program Files\NetApp\OnCommand System Manager\ to negate this requirement.

/end edit/

Somewhat hackish as I said but it works. You could of course use IE or FireFox (or anything else if it works) if that is your preference. Make sure you update the $OnCommandPath to match your install location.

Message was edited by: Michael Thomas

cori_grieb

Michael,

Thank you for the suggestion.  I'm not sure exactly what the cause was but after starting to attempt your method (actually just installing Chrome), System Manager loads just fine without even using the method or even Chrome.  I'm not sure if it was due to a recent Windows update or the installation of Chrome which got everything straightened out but I'm happy it's playing nice now with IE10.  I had to also use the compatibility button to enable the add button functionality.

Thank you,

-Cori

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

Public