Active IQ Unified Manager Discussions

Redundant relationships found

sswain123

I came across a non-conformance issue on one of my datasets…Preview Conformance stated that there was an issue with a couple of the SV relationships…the suggestion was to import those relationships into the dataset.  I browsed to External Relationships and found my SV’s for that dataset sitting in there….so, I imported them.  Shortly after, the non-conformance error went away but, now I’m faced with another…this time it’s telling me there are duplicate relationships.

/snip

Conformance Results

=== SEVERITY ===

Error:     Attention: Found 10 redundant relationships.

=== ACTION ===

Check for redundant relationships.

=== REASON ===

Redundant relationships found.

=== SUGGESTION ===

Cleanup the redundant relationships.

I’m not sure the process required to remove them…any thoughts or suggestions?

Thanks,
Scott

8 REPLIES 8

adaikkap

Hi Scott,

          By definitions a redundant relationship is a one that duplicates the needs of a given PM dataset connection which is already taken care by another existing relationship.

Can you get the output of the following?

dfpm dataset list –m <dsname>

dfpm dataset list -R <dsname>

dfpm dataset list -l <dsname>

dfpm relationship list –r

dfm options list | grep -i reaper

Regards

adai

adaikkap

Hi Scott,

     Just wanted to know the status of the datasets since we did the necessary actions to remove the redundant relationships.

Regards

adai

bshep8384

Adaikkappan,

I ran dfpm relationship list -r and now can see my redundant relationships.  Now what do I do to remove them?

Thanks,

Shep

adaikkap

Hi Shep,

     Here are your steps to clean up an redundant relationship.

Make sure your dpReaperCleanupMode is set to ORPHANS or NEVER.

A relationship is marked redundant only if for a given source qtree you have more than one destination and all of that being managed in the same dataset.

Use the dfpm  relationship list -r command as well as the dfpm dataset list -m <dataset name> and  you should see the two relationships with same source names. But   Note that only 1 may be marked as redundant as it is redundant in terms of the other one

Now for the redundant relationship do a snapvault stop on the storage system to stop the relationship that is marked as redundant.

After about  2 hour you should see that your  datasets goes back to conformant state.

Regards

adai

gdefevere

Hi Adaikkappan,

I have something strange. I've dataset SME snapvault. It has 34 qtree relationships. 8 of them are double entries (so 16 in total) with the same source and destination. One of these doubles is up-to-date, the other has a lag of 9 days. These 8 out of data entries are also listed in the external relationships.

What I did : I imported one (for test) in the hope that OnCommand would figure out that is double and would fix it. Unfortunately it didn't turned out this way. The dataset became unconformant with the message : Found 1 redundant relationships. If I run "dfpm relationship list -r", the out of date one is show. However on the dest filer, I only see one relationship ! Stopping this one will probably not be a smart move !?

vreddypalli

Hi,

We are also facing similar issue.  Can you please paste the steps here to remove the redundant relations from the dataset..?

Thanks in Advance.

Regards,

Vijay R

LOSLUCIFER

Hi.

Im new to this and i also have a problem with redundant relationship. My backup fails.

Need the guide to clean up.

OSSV Error:

Found 1 redundant relationships.
Check for redundant relationships.

Redundant relationships found.

Cleanup the redundant relationships.

How do i do this?

Regards,

Kristoffer L - Norway

sdgayle

What were the steps that were taken to correct this issue?

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public