Active IQ Unified Manager Discussions

OnCommand SysMgr 3.1RC1 broken by jre 7u51 on Win7x64



I updated from jre 7 u45 to u51, I also removed the old version and now OCSM 3.1RC1 fails to start (no error messages). When I run the OCSM installer it complains that there is no 64 bit version of java installed. So I backrevved to jre 7 u45 and OCSM 3.1RC1 now starts properly. Yay Java! Write once run anywhere? Ha, how about Write Many/Run None instead...





Just wanted to point out that full-blown System Manager 3.1 also fails to load on JRE 7u51.  I also had to download an old version of JRE 7u45 to get System Manager 3.1 working properly.

I'll enter a ticket with NetApp to see if they'll put a notice on the release notes.


Same here - Win7SP1x64, tried both JRE 7u51 and JRE 7u55 versions and both System Manager 3.0 and System Manager 3.1 is not even launching 😐

After reverting back to JRE 7u45 - still no luck.

Then tried with JRE 8u5, still nothing.

But after manually trying to launch "SystemManager.jar" instead of "SystemManager.exe" - all is good


Glad to hear that worked out for you, Karlis.  I'll have to keep that option in mind.

I entered a P4 ticket requesting an update to the release notes and, if possible, a failure message if the executable is launched with an unsupported version of Java.  If I get a response to the ticket I'll let you guys know.


Anything after JRE 45 isnt working. If you had 45 working before an upgrade and now it isn't, put the JAVA dir in you path. That allowed the old version to work.

Still can't get new versions of Java to be seen.


I am able to launch and operate OCSM 3.1RC1 on both versions of Java on Win7 X64:

C:\>java -version

java version "1.7.0_45"

Java(TM) SE Runtime Environment (build 1.7.0_45-b18)

Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)


C:\>java -version

java version "1.7.0_55"

Java(TM) SE Runtime Environment (build 1.7.0_55-b13)

Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)



OS Name:                   Microsoft Windows 7 Enterprise

OS Version:                6.1.7601 Service Pack 1 Build 7601


Is there anything else you can share regarding your systems that might help narrow down the cause?




Did you perform a "remove all previous versions"? When I did that, it stopped working. I had to remove all versions, install update 45, and then upgrade to the latest.


I don't recall seeing that option in the offline installer/upgrade routine. 

I removed the only other Java I had showing in the control panel (Java 7 Update 9) leaving only this entry:

OCSM still launches:




To anyone who has a case open for this behavior, please post or PM me your #. 

Also be sure to have provided a support bundle to your case owner.