Active IQ Unified Manager Discussions

OnCommand Unified Manager 6.4RC1 Upgrade error

GROOVE

Just run the in place upgrade on our 6.3 box , all completed successfully with no errors, however now getting this when attempting to load the page

 

Reverse proxy doesn't have a mapping for the url for resource : '/' with method 'GET'

 

 

Any ideas ?

1 ACCEPTED SOLUTION

msaravan

Thank you for the output.

 

If it is vApp, we have another solution for that. You can change the hostname via vApp console options.

 

Login to the vApp via SSH with maintenance user account.

Go to options 3 -> 11.

You can enter the new hostname, and go for option 10 to reset server certificate.

Then reboot the vApp as suggested in the output of option 10.

 

This will help you to fix this problem.

 

Regards,

Saravanan

View solution in original post

20 REPLIES 20

msaravan

Hi,

 

I think, your machine doesn't have full FQDN configured. Whats your host OS ? Is it Windows, vApp or RHEL ?


If it is vApp or RHEL, can you please execute the following commmands and share the output.

 

hostname

ping `hostname`

ping6 `hostname`

 

Try to make entries into /etc/hosts with FQDN host name, and reboot the box.  Post the reboot, this error is expected to be fixed.

It it sill persists, please share your /etc/hosts config as well.

 

Regards,
Saravanan

GROOVE

Hi THanks for your reply

 

its the VM vApp version.

 

So I will need to login as diag user into the OCUM Vapp box and run those commands ?

 

/etc/hosts needs to be edited on the OCUM box with its own hostname ?

 

THanks

GROOVE

ocm.png

 

 

Output as requested.

GROOVE

hosts.png

msaravan

Thank you for the output.

 

If it is vApp, we have another solution for that. You can change the hostname via vApp console options.

 

Login to the vApp via SSH with maintenance user account.

Go to options 3 -> 11.

You can enter the new hostname, and go for option 10 to reset server certificate.

Then reboot the vApp as suggested in the output of option 10.

 

This will help you to fix this problem.

 

Regards,

Saravanan

View solution in original post

GROOVE

Worked for me 🙂

 

Back up and running.

 

just changed name via mena to FQDN and updated the cert as suggested.

 

Back in business...nor for OPM 😉

olaf_hoetger

Hi GROOVE, can you please post your hosts file with the OCUM working again?

regards,

Olaf

olaf_hoetger

Hi ,

perhaps you can help again, we still get the error:

"Reverse proxy doesn't have a mapping for the url for resource : '/' with method 'GET'"

regards,

Olaf

msaravan

Hi Olaf,

 

Can you please share the content of your /etc/hosts file

 

Did you reset the certificate after the host name change from "OnCommand" to "OnCommand.<domain_name>" ?

 

If possible, can you please share the last few lines of /var/log/ocum/rp-<date>.log ?

 

Regards,

Saravanan

 

olaf_hoetger

Hi,

 

if found these lines in the metioned rp log file:

 

2016-02-26T15:05:18.278Z - error: Validation Errors are: [ { param: 'ip',
    msg: 'value is not a valid IP',
    value: 'OnCommand.domain.local' },
  { param: 'ip',
    msg: 'value is not a valid FQDN',
    value: 'OnCommand.domain.local' } ]
2016-02-26T15:05:18.278Z - error: IP Error
2016-02-26T15:05:18.278Z - error: FQDN Error

 

 

Host file looks like this:

 

127.0.0.1       localhost
127.0.1.1       OnCommand.domain.local OnCommand
::1             localhost ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

 

(real names changed ...)

 

regards,

Olaf

msaravan

Thanks Olaf for the output.

 

I understand that you have changed the hostname.

 

Is it really "OnCommand.domain.local" or you named it like that here to secure your actual domain name from our visibility ?

If so, I can also use "OnCommand.domain.local" in my local lab, and try to repro your error.

 

Other than that, I have other 3 questions:

1. Did you reset the server certificate post the hostname change ?

2. Did you reboot your box post the hostname change ?

3. For the domain name you used in the hostname, did you configure the right DNS server in your host configuration ?  Can you check your /etc/resolv.conf and get back ?

 

Sorry for asking more questions, but I want to see where the problem in the configruation.

 

Regards,

Saravanan

olaf_hoetger

Hi msaravan,

 

Is it really "OnCommand.domain.local" or you named it like that here to secure your actual domain name from our visibility ?

Yes i changed the actual domain name for security reasons.

 

1. Did you reset the server certificate post the hostname change ?

Yes

 

2. Did you reboot your box post the hostname change ?

Yes

 

3. For the domain name you used in the hostname, did you configure the right DNS server in your host configuration ?  Can you check your /etc/resolv.conf and get back ?

Yes, I can successfully resolve hostnames in the actual domain. But only on diagnostics console, not at maintenance console (Menue 2 + 10).

 

btw. in the meantime I also opened a case at official netapp support ...

 

regards,

Olaf

msaravan

Thank you olaf. I hope the support team will take care of.

 

I assume yours is a upgrade scenario, and not a fresh installation.

As a last try, can you please share the below data to come to a conclusion:

 

1. Output of /opt/netapp/essentials/data/app_regitry.json

2. The last few lines of log /var/log/ocum/ocumserver-debug.log  - where you could see some put/post requests sent.I want to see those relevant lines.

 

Regards,

Saravanan

olaf_hoetger

Hi ,

 

yes, it was an upgrade scenario from 6.3 to 6.4RC1.

 

output of /opt/netapp/essentials/data/app_registry.json is:
[]

 

Extract from /var/log/ocum/ocumserver-debug.log:

[...]

2016-02-29 12:56:26,946 INFO  [oncommand] [Thread-2] [c.n.d.c.r.CurrentRPRegistryUpdateService] Request to update RP's metadata for UM as part of server startup :
2016-02-29 12:56:27,008 INFO  [oncommand] [Thread-2] [c.n.d.c.r.r.HttpsRestTemplate] Sending (GET) request to URL (https://changedhostname.changeddomain.com:8443/api/registry/um)
2016-02-29 12:56:27,020 DEBUG [oncommand] [Thread-2] [c.n.d.c.r.r.HttpsRestTemplate] Created GET request for "https://changedhostname.changeddomain.com:8443/api/registry/um"
2016-02-29 12:56:27,110 DEBUG [oncommand] [Thread-2] [c.n.d.c.r.r.HttpsRestTemplate] Setting request Accept header to [application/json, application/*+json]
2016-02-29 12:56:27,111 DEBUG [oncommand] [Thread-2] [c.n.d.c.r.r.HttpsRestTemplate] Writing [parameters] using [org.springframework.http.converter.StringHttpMessageConverter@4a5cf54a]
2016-02-29 12:56:27,117 INFO  [oncommand] [Thread-2] [c.n.d.c.r.r.HttpRequestInterceptor] Request:
endpoint : https://changedhostname.changeddomain.com:8443/api/registry/um
type : GET
body : parameters
2016-02-29 12:56:27,268 INFO  [oncommand] [Thread-2] [c.n.d.c.r.r.HttpsRestTemplate] Caught exception while issuing rest call from UM to RP: I/O error on GET request for "https://changedhostname.changeddomain.com:8443/api/registry/um": https://changedhostname.changeddomain.com:8443/api/registry/um; nested exception is java.io.FileNotFoundException: https://changedhostname.changeddomain.com:8443/api/registry/um
2016-02-29 12:56:27,269 ERROR [oncommand] [Thread-2] [c.n.d.c.r.r.RpRegistryUpdateService] Error fetching registry entry for UM : Registry Retrieve failed : response was NULL
2016-02-29 12:56:27,269 INFO  [oncommand] [Thread-2] [c.n.d.c.r.r.RpRegistryMetadataProvider] current RP metadata string :{"sysId":"um","ip":"localhost","name":"um","type":"um","port":"20443","cluster":[],"urls":[{"url":"/um/OnCommand/service/", "skipAuth":"false"},{"url":"/um/OnCommand/DataPolicy/", "skipAuth":"false"},{"url":"/um/restServices", "skipAuth":"false"},{"url":"/um/restApis", "skipAuth":"false"},{"url":"/um/actuateJavaComponent", "skipAuth":"false"}]}
2016-02-29 12:56:27,320 INFO  [oncommand] [Thread-2] [c.n.d.c.r.r.RpRegistryUpdateService] Clusters for registry update : 0b591e2f-bc2c-11e4-8a59-00a098611f44;95b4960b-bc3b-11e4-8687-00a098612180;632eabfe-ed79-11e2-9f6a-123478563412;021fc828-255d-11e3-bf34-123478563412;8b7ff558-bc2b-11e4-9dfc-00a098612458;d89cf836-2553-11e5-91c5-90e2ba70a6ec;306d6fc8-26ed-11e5-ae80-90e2ba70ab58;3d2fd527-bc3b-11e4-9fb4-00a09861192c
2016-02-29 12:56:27,368 INFO  [oncommand] [Thread-2] [c.n.d.c.r.r.RpRegistryUpdateService] Urls for registry update : [{"url":"/um/OnCommand/service/","skipAuth":false},{"url":"/um/OnCommand/DataPolicy/","skipAuth":false},{"url":"/um/restServices","skipAuth":false},{"url":"/um/restApis","skipAuth":false},{"url":"/um/actuateJavaComponent","skipAuth":false}]
2016-02-29 12:56:27,378 INFO  [oncommand] [Thread-2] [c.n.d.c.r.r.HttpsRestTemplate] Sending (POST) request to URL (https://changedhostname.changeddomain.com:8443/api/registry/)
2016-02-29 12:56:27,378 DEBUG [oncommand] [Thread-2] [c.n.d.c.r.r.HttpsRestTemplate] Created POST request for "https://changedhostname.changeddomain.com:8443/api/registry/"
2016-02-29 12:56:27,379 DEBUG [oncommand] [Thread-2] [c.n.d.c.r.r.HttpsRestTemplate] Writing [{sysId=[um], name=[um], ip=[changedhostname.changeddomain.com], type=[um], port=[20443], clusters=[0b591e2f-bc2c-11e4-8a59-00a098611f44;95b4960b-bc3b-11e4-8687-00a098612180;632eabfe-ed79-11e2-9f6a-123478563412;021fc828-255d-11e3-bf34-123478563412;8b7ff558-bc2b-11e4-9dfc-00a098612458;d89cf836-2553-11e5-91c5-90e2ba70a6ec;306d6fc8-26ed-11e5-ae80-90e2ba70ab58;3d2fd527-bc3b-11e4-9fb4-00a09861192c], urls=[[{"url":"/um/OnCommand/service/","skipAuth":false},{"url":"/um/OnCommand/DataPolicy/","skipAuth":false},{"url":"/um/restServices","skipAuth":false},{"url":"/um/restApis","skipAuth":false},{"url":"/um/actuateJavaComponent","skipAuth":false}]]}] as "application/x-www-form-urlencoded" using [org.springframework.http.converter.support.AllEncompassingFormHttpMessageConverter@696ec652]
2016-02-29 12:56:27,380 INFO  [oncommand] [Thread-2] [c.n.d.c.r.r.HttpRequestInterceptor] Request:
endpoint : https://changedhostname.changeddomain.com:8443/api/registry/
type : POST
body : sysId=um&name=um&ip=changedhostname.changeddomain.com&type=um&port=20443&clusters=0b591e2f-bc2c-11e4-8a59-00a098611f44%3B95b4960b-bc3b-11e4-8687-00a098612180%3B632eabfe-ed79-11e2-9f6a-123478563412%3B021fc828-255d-11e3-bf34-123478563412%3B8b7ff558-bc2b-11e4-9dfc-00a098612458%3Bd89cf836-2553-11e5-91c5-90e2ba70a6ec%3B306d6fc8-26ed-11e5-ae80-90e2ba70ab58%3B3d2fd527-bc3b-11e4-9fb4-00a09861192c&urls=%5B%7B%22url%22%3A%22%2Fum%2FOnCommand%2Fservice%2F%22%2C%22skipAuth%22%3Afalse%7D%2C%7B%22url%22%3A%22%2Fum%2FOnCommand%2FDataPolicy%2F%22%2C%22skipAuth%22%3Afalse%7D%2C%7B%22url%22%3A%22%2Fum%2FrestServices%22%2C%22skipAuth%22%3Afalse%7D%2C%7B%22url%22%3A%22%2Fum%2FrestApis%22%2C%22skipAuth%22%3Afalse%7D%2C%7B%22url%22%3A%22%2Fum%2FactuateJavaComponent%22%2C%22skipAuth%22%3Afalse%7D%5D
2016-02-29 12:56:27,435 INFO  [oncommand] [Thread-2] [c.n.d.c.r.r.HttpsRestTemplate] Caught exception while issuing rest call from UM to RP: I/O error on POST request for "https://changedhostname.changeddomain.com:8443/api/registry/": Server returned HTTP response code: 400 for URL: https://changedhostname.changeddomain.com:8443/api/registry/; nested exception is java.io.IOException: Server returned HTTP response code: 400 for URL: https://changedhostname.changeddomain.com:8443/api/registry/
2016-02-29 12:56:27,436 ERROR [oncommand] [Thread-2] [c.n.d.c.r.CurrentRPRegistryUpdateService] Unable to update RP registry with UM's metadata Registry Update failed : response was NULL, refer logs for more details

[...]

 

(again replaced actual FQDN with changedhostname.changeddomain.com...)

 

regards,

Olaf

 

GROOVE

So have both OCM and OPM upgraded now. BUt configuring Full integration is still eluding me.

 

I get the new Dash in OCM , but the following is showing unde the cluster - 

 

Pairing Status : Bad

 

Ive gone through setting up the pairing in OPM again , setup new accounts with the correct roles ( admin and Event Pub ) but just cannot seem to get them talking.

 

I take it when in Full integration mode there is no longer a way to go to the OPM URL directly as I am seeing a dertificate error if I do.

 

Andy

msaravan

I assume you are looking for full integration pairing b/w OCUM 64 + OPM 21. I hope both are upgraded setups (6.3 upgraded to 6.4,  and 2.0 upgraded to 2.1).

 

There is a heartbeat channel established b/w OPM and OCUM. If that fails, then the pairing status is marked as BAD.

 

It has auto-heel capability and OPM tries to communicate with OCUM every 5 mins. Once the proper connection is established the pairing status will be turn to Good.  Can you please wait for few more mins, and

share us the screenshot.

 

In full integration mode, you can not login to OPM URL directly.  To go to OPM, you have to use the navigation path of UM -> Dashboard drop down button -> Performance. This is the only way to follow to land into OPM web GUI.

 

Regards,
Saravanan

GROOVE

Apologies for no replies recently.....

 

I rolled the updates back , and reverted to snapshots as I couldnt get them talking.

 

Now my previous versions are not talking 😞 Going to fix that and attempt an upgrade again.

FLORENETAPP

Same issue for me. 

Pairing Status: Bad

 

OCUM in Version 6.4RC!

OCPM in Version: 2.1.0RC1

 

Thanks for your help. 

 

 

IMHOTEPSON

maybe this will help after hostname change and reset of certificates...

https://kb.netapp.com/support/s/article/ka31A00000012k3QAA/internal-how-to-regenerate-certificates-in-unified-manager-6-4-for-rhel-instance?language=e...

on an appliance this should be done with the diag user login

olaf_hoetger

Hi, we have exact the same error, and followed your steps. Unfortunately this did not resolve the problem.

regards

Olaf

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public