Active IQ Unified Manager Discussions

OnCommand Unified Manager + VMware Workstation?


Another OCUM question for you experts,


In order to be able to experiment a little, I am trying to install the OCUM 7.1 .ova appliance image in VMware Workstation 12.5.2 on my laptop (Windows 10).


Unfortunately I fell at the first hurdle :-(.


As the OCUM system boots for the first time, in the console window of the guest I see this message:


Booting OnCommand Unifed Manager virtual appliance...

VMware Tools installation


Please select VM | Guest | Install/Upgrade VMware Tools for this virtual machine in the vSphere Client.

Installation/Upgrade will then proceed automatically.


In the VMware Workstation product the menu option to install the Tools package is "VM -> Install VMware Tools", however this option is greyed out.


So at this point I seem to be deadlocked, the OCUM "install" or setup won't continue until the VMware Tools are installed, but the option to install the Tools is not available.


In the VMware guest hardware settings I tried changing the device settings for the CDROM/DVD from "Auto detect" to "Use ISO image file" and specifying a random .iso file (the laptop has no physical CDROM/DVD drive). I also tried disabling VMware software updates in preferences. However the Tools install option remains greyed out, even after restarting VMware Workstation.


Does anyone know why this would be, or how to fix it?


What is the OCUM guest image doing at this point? Does it actually require the VMware Tools package? Is there some way to skip this step in the installation?


Thanks in advance for any advice!






Re: OnCommand Unified Manager + VMware Workstation?


Re: OnCommand Unified Manager + VMware Workstation?


The VMware KnowledgeBase?!? You will never find a more wretched hive of ... Oh, sorry that's Star Wars 🙂


Actually I found the following links useful:


I'll add the solution separately "below".


Re: OnCommand Unified Manager + VMware Workstation?


FYI, with the help of the links mentioned I was able to get the OCUM appliance working in VMware Workstation.


It seems the appliance image does indeed require the VMware Tools.

It is necessary to set the VMware guest hardware settings for the CDROM/DVD to "Use ISO image file".

There is a downloadable file (zip or tar.gz) that contains ISO images of the Tools package for the various guest Operating Systems, it is available from the VMware product support site via:


(It's not clear to me if this is the current version of the Tools package or not.)


It is also necessary to set the CD/DVD device to "Connect at power on". Make sure to save and (re-)check this setting (I didn't!).


When rebooted the guest image should then find the VMware Tools package and automatically install it. The guest will then begin its setup process, prompting you for network inormation.


Subsequently I had another issue. The network settings could not be applied because of a init script error "Mounting HGFS shares FAILED". The fix for this is also in the VMware guest settings, it is necessary to enable "Shared Folders" and add an entry under Folders for a shared path.


Hopefully this summary is useful to someone.



View solution in original post

Re: OnCommand Unified Manager + VMware Workstation?


The issue here is VMware Workstation doesn't know which tools iso to load.  The OVF calls out the guest OS as "other26xLinuxGuest64", but on import Workstation is mapping it to Other/Other.  Before powering on the VM, set it to Linux/Other Linux 2.6x kernel 64-bit.  Then under shared folders, set it to "Always Enabled", otherwise the HGFS driver will fail to load and the tools script will keep reverting your IP changes.  

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Earn Rewards for Your Review!
GPI Review Banner
All Community Forums