The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Problems with connection to the client

jonas

Hi.

We have an new server with a new install of 6.4.2.

When we open the client it does not start, it does not give us an error message.

Whe i look in the client log i can find the following error:

Client failed to start properly - Could not initialize class com.onaro.sanscreen.server.interfaces.ServerInterfacesUtils

Java version is 1.7.09

Does anyone have any idee?

Regards

Jonas

7 REPLIES 7

hotz

Jonas,

are you starting the client on the server itself (via RDP) or from your desktop?

Either way, I'd check the network settings of java (in the control panel) and change the default proxy settings to direct connectivity. And maybe delete the java cache.

Otherwise try from a different machine possibly with a different java version installed.

Hope this helps.

Gerhard

jonas

The problem occurs on both client and on the server itselfe(RDP).

I’m going to try a later Java version.

Mvh/Regards

Jonas Enhörning

Duke Systems AB

Tel +46 8 765 48 80

Från: Gerhard Hotz

Skickat: den 5 februari 2014 16:43

Till: Jonas Enhörning

Ämne: - Re: Problems with connection to the client

<https://communities.netapp.com/index.jspa>

Re: Problems with connection to the client

created by Gerhard Hotz<https://communities.netapp.com/people/hotz> in OnCommand Insight - View the full discussion<https://communities.netapp.com/message/124953#124953>

Jonas,

are you starting the client on the server itself (via RDP) or from your desktop?

Either way, I'd check the network settings of java (in the control panel) and change the default proxy settings to direct connectivity. And maybe delete the java cache.

Otherwise try from a different machine possibly with a different java version installed.

Hope this helps.

Gerhard

Reply to this message by replying to this email -or- go to the message on NetApp Community<https://communities.netapp.com/message/124953#124953>

Start a new discussion in OnCommand Insight by email<mailto:discussions-community-products_and_solutions-storage_management_software-oncommand--insight@communities.netapp.com> or at NetApp Community<https://communities.netapp.com/choose-container.jspa?contentType=1&containerType=14&container=3203>

hotz

Hi Jonas,

it might also be a good idea to look into the client log file on the client machine: %HOMEPATH%\Local Settings\Application Data\SANscreen\configuration\xxxxxxxxxxxxx.log. If you have more than one file in the directory, look for the one with the matching time stamp and see if there's any useful hints in the log as to what might be causing the issue.

Also, make sure port 80 of the OCI server is reacheable and the Senscreen Server service is up and running.

jonas

Hi.

It turns out taht it seem s to be a firewall issue.

The oci server is behind a firewall withg port 80 and 443 open.

But the ociserver anseres back on some random 60000 port.

Is there any setting to get a fixed port range?

Mvh/Regards

Jonas Enhörning

Duke Systems AB

Tel +46 8 765 48 80

Från: Gerhard Hotz

Skickat: den 6 februari 2014 10:39

Till: Jonas Enhörning

Ämne: - Re: Problems with connection to the client

<https://communities.netapp.com/index.jspa>

Re: Problems with connection to the client

created by Gerhard Hotz<https://communities.netapp.com/people/hotz> in OnCommand Insight - View the full discussion<https://communities.netapp.com/message/124998#124998>

Hi Jonas,

it might also be a good idea to look into the client log file on the client machine: %HOMEPATH%\Local Settings\Application Data\SANscreen\configuration\xxxxxxxxxxxxx.log. If you have more than one file in the directory, look for the one with the matching time stamp and see if there's any useful hints in the log as to what might be causing the issue.

Also, make sure port 80 of the OCI server is reacheable and the Senscreen Server service is up and running.

Reply to this message by replying to this email -or- go to the message on NetApp Community<https://communities.netapp.com/message/124998#124998>

Start a new discussion in OnCommand Insight by email<mailto:discussions-community-products_and_solutions-storage_management_software-oncommand--insight@communities.netapp.com> or at NetApp Community<https://communities.netapp.com/choose-container.jspa?contentType=1&containerType=14&container=3203>

ostiguy

The OCI client should make all of its communication to the https port of the OCI server - it may locally have some ports open, but all the network traffic should be to a destination port of 443, or whatever the port is.

The sanscreen-client.log would be helpful

This may be a name resolution issue.

jonas

Hi Thanks for the clarification.

It turned out to be a Java issue.

Mvh/Regards

Jonas Enhörning

Duke Systems AB

Tel +46 8 765 48 80

Från: ostiguy

Skickat: den 6 februari 2014 16:51

Till: Jonas Enhörning

Ämne: - Re: Problems with connection to the client

<https://communities.netapp.com/index.jspa>

Re: Problems with connection to the client

created by ostiguy<https://communities.netapp.com/people/ostiguy> in OnCommand Insight - View the full discussion<https://communities.netapp.com/message/125039#125039>

The OCI client should make all of its communication to the https port of the OCI server - it may locally have some ports open, but all the network traffic should be to a destination port of 443, or whatever the port is.

The sanscreen-client.log would be helpful

This may be a name resolution issue.

Reply to this message by replying to this email -or- go to the message on NetApp Community<https://communities.netapp.com/message/125039#125039>

Start a new discussion in OnCommand Insight by email<mailto:discussions-community-products_and_solutions-storage_management_software-oncommand--insight@communities.netapp.com> or at NetApp Community<https://communities.netapp.com/choose-container.jspa?contentType=1&containerType=14&container=3203>

hotz

I'm not aware of any way to change that.
I tried it out too and I could see tcp packets in the port range 4056-4191, but i think higher values are possible too, since the port numbers seem to grow sequentially with the packet numbers. Best to allow UDP/TCP and IP packets from the OCI server to the client host without restrictions. Or you'd have to stick with RDP to the OCI serevr, if the client is running from there. Best advice I can give.

Hope this helps.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public