Active IQ Unified Manager Discussions

SLO Pack - Service Catalog Initialization. Unable to contact WFA service url http://localhost...


After getting the pre-requiste perl modules installed today I've repatedly tried to execute the 'Service Catalog Initialize' workflow and repeatedly get an error similar to: 


     Unable to contact WFA service url http://localhost:80/rest/execution/jobcommand/8f905378-3aee-421c-8cb4-ad8b1435d203 at C:/Program Files/NetApp/WFA/Perl64/lib/ line 551, <STDIN> line 1.


... at different steps within the workflow


Each one of errors comes after a 3-minute delay so I'm assuming something is timing out. I've noticed these symtoms and tried a few things:

  • it is not always the same command step. The example below shows it failing on step-3 but I've also seen it run through to step-8 (Install QoS Service ) and then fail on that steps with the same error ... it has failed this way one 3 different steps at different runs (out of the fisrt 8 steps)
  • wondering if a credential for 'localhost' was in play (I had one setup previously) I changed it, and finally deleted it, seeming to make no difference - is anything required in he way of a credential (localhost) for this pack?
  • when running a second time I'll sometimes go into the WFA Cache DB and pre-delete (drop) all the tables it was able to create on the last run, seems to make no difference
  • I've looked at workflow logs and just don't see anyting revealing


Here is screenshot of error:


Screen Shot 2015-08-31 at 3.43.20 PM.png


I've attached

  • workflow log .zip after a failure.
  • log of most recent ppm installs



  • Windows 2008R2 Standard SP1
  • WFA 3.0P1
  • SLO Pack 1.1.0

This seems intermittment since it's has occured at 3 different command steps in the workflow, all with essentually the same 'Unable to connect' error following a 3-minute delay. 


Ideas for things to look into? This WFA server has been in use for over a year.



Additional information:

  • Uninstalled WFA 3.0P1
  • Installed WFA 3.0P1 and DID NOT restore it's database
  • Added OCUM data-source and a couple of credentials
  • Did the three ppm installs for prerequsite perm modules
  • Imported the SLO Pack 1.1.0
  • Executed Service Catalog Initialize - after ~ 3-minute stall get the same error (log zip file attached)
  • Went into Designer->Commands and attempted to test 1st cmd step - Create Service level Class Table - after ~ 3-minute stall get the same error 
  • Screen capture of stand-alone command error follows
  • Also attaching Workflow execute logs where 1st step fails



More additional information:

  • On a a DIFFERENT relatively new and virgin w2k8r2 server with only SnapDrive installed. WFA has never been installed on this server before.
  • Installed WFA 3.0P1
  • added a data-source and a couple of credentials
  • Installed the 3 perl modules
  • Imported the SLO Pack 1.1.0
  • Executed the 'Service Catalog Initialize' workflow -- seems to have run fine !!!

So this problem is related to the original WFA Server. This WFA server ahs been in constant use for 12-18 months (inlcuding upgrades from 2.2 to 3.0, etc)


To test a possible theory that something about this WFA server can't run perl commands I do the following: 

  • Find a built-in cDOT WFA Perl Command: 'Create Schedule'
  • Test run this command to create a type=cron schedule
  • I get roughly the same error on from that command.
  • Screen capture follows:

What further debug/analysis steps could I take to isolate why perl commands are failing on this WFA environment?  





Wondering if this had to do with a bad path or lib pointer on one systems and not the other I've attached two text files. These include windows cmds:

 - set (which shows env variables)

 - perl -v (shows version)

 - perl -V (shows more)


The files are:

 - w2k8r2-where-wfa-perl-DOES-NOT-WORK.txt - from the original WFA server this post was opened for

 - w2k8r2-where-wfa-perl-WORKS.txt - from the second different WFA server I stood up where SLO Service Catalog Workflow ran fine


I don't know what I'm looking for so they tend to look the same to me.



here is second file

Can you check if there is other version of perl installed in machine where it is not working? You can check installed perl version in the setup.


Not sure exactly what you mean by 'check the setup' but nothing about any version of perl shows up in the Control Panel to 'Uninstall' a version of perl. To my knowledge the only perl on the system is that which is sitting under the \NetApp\WFA\perl64 path. But if there is some other way to check let me know.