Active IQ Unified Manager Discussions

SMHV Task Scheduler doesnt work - Windows Server 2016


Hello all,


i installed SnapManager for Hyper-V in the Version 2.1.2 on both 2- Node Cluster Server. (Windows Server 2016)

All works fine, but the scheduled task doesn't work!


I configured a Dataset with scheduler Policy - so the Task start and end within 20 seconds. Result: Succes - but no backups are created.


SnapManager for Hyper-V\Backup report:


[17.03.2017 11:30:35, (25)] The operation completed successfully.
[17.03.2017 11:30:35, (25)] AutoSupport is disabled, AutoSupport update will not be performed
[17.03.2017 11:30:35, (25)] Backup task: completed successfully
[17.03.2017 11:30:35, (25)] <?xml version="1.0" encoding="utf-16"?>
<VMStatusResult xmlns:xsd=""
  <VM Name="VM-01" Id="35a19b6f-a903-9687-bd8b-b053da809361" Result="OK" />


The Job-ID is Dataset_[job]cc_Dataset_Policy_01-01-0001_00.00.00   - i think there is an mistake? time? date?


Recovery Tab: The selected dataset or virtual machine has no backups.


Windows Log:

SnapManager for Hyper-V backup failed to complete

An error occured while executing SnapManager backup job.

Job: new-backup -ds CORE_Dataset -pid Dataset_Policy -h Cluster1 -scid 2918e971-abb2-4a5b-ad31-5773a46887df

Details: An error occured while invoking the powershell cmdlet.

Input Not Valid, Specfied scheduled job is not found in the task list

EventID: 106

Source: SnapMgrServiceHost


When i run the job manually it works, but it won't run at the scheduled time. 😞

Complete uninstall, try an older version from SMHV 2.1, delete files and reinstall with new configuration, still the same!


Has anyone seen this issue, og have any ideas what could be the reason?




SnapDrive 7.1.4

SnapManager for Hyper-V 2.1.2

Windows Server 2016

2- Node Cluster


Thanks for your help!!

If you need more information - let me know!



Kind regards,






It might be due to bug:

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Hi Sahana,


thanks for the information about this bug.

I'm still waiting for the solution.







update here?

i need a solution..




Were you able to find a solution for this problem?




Rui Paiva



I have the same problem/bug.
Anyone that has found a workaround?
I have created a case with Netapp on this.. but I really need this to get up and running.




Best regards, Pelle



Hello to everyone


I also have problem with SnapManager for Hyper-v on Windows Server 2016 but my problem is different.

My backups are running on schedule but the problem is that Application consistant backup are failing withe error that SnapManager cannot rename Snapshot.


We opened the case at NetApp and NetApp said that we have to install Host Guardian Service role on the Windows Server 2016 hosts.

We did this and SnapManager is now working but the problem is that installation of HGS role depends on AD DS and IIS role.

You cannot install HGS role, unless you install also AD DS and IIS role.


Now I have on my Hyper-V hosts HGS, AD DS and IIS role and on every host I have, in Server Manager is post deployment task waiting to promote this host to a domain controller.


I am not happy with this scenarion and I am asking you ... did you also had to instal HGS role in Windows Server 2016 Hyper-V host to make SnapManager work?


Thank you


Best regdars



That would interest me too! I refuse to install  the HGS until i get an technical explanation why. In most Hyper-V scenarios HGS is not need.


Thanks for any reply.



Best regards



We have 2 Windows 2016 Hyper-V Clusters, and both with the task manager issue. After contact NetApp support, we managed to get one of the clusters working by invoking the powershell command created by SMHV in a manually created task (in task manager).


Short after that, we were informed that SMHV 2.1.2P1 should solve that issue, but on our main cluster, the issue remains. We've also been advised to install HGS role (without configuration)... we're in the middle of that... very annoying ...


Hi Guys!


It is a bug. I have the same problem here. I found a solution  using Snap Manager for Hyper-v powershell Extension.  


This is the code I used (You can customize as your needs)


Import-module SMHV

New-Backup -Dataset 'Data_set_name' -RetainBackups 3 -CrashConsistentBackup -Host 'CLU_NAME' -Verbose    



Save the code above in a .ps1 file and create a new schedule task using the script.





















Server 2016 / Hyper-V / Netapp Ontap 8.2.5


I also experienced the errors with snapmanager for hyper-v, so went ahead and installed the host guardian service / domain services.


I am still waiting for a fix for the scheduled task not running.   2.1.2P1




The issue I am having is that I have now clustered the two hyper-v Nodes.   And am having an issue making my netapp luns available in the cluster.


According to the bloggs I have read, the issue is due to the hosts being DCs (required by HGS)


Has anyone else installed the HGS on their Hyper-v cluster??



my test cluster had no issues at all, but did not have the HGS service installed.




I have another issue with Win 2016 and SMHV.


I've upgraded our 3-node Hyper-V cluster from Win 2012R2 to Win2016.

After upgrade of the last node in the cluster, the backup is stopped working at all.

As I can see in the logs, SMHV is created : "{GIUD}" snapshot, but doesn't create "{GUID}_backup" snapshot.

Backup failed because this snapshot is not existing and SnapDrive can't rename these snapshots to normal SMHV name.




Wed Jul  4 23:34:53 [hq-str3-a:wafl.snap.delete:info]: Snapshot copy {7196c57a-52a7-426d-9775-14cf7c0d2ae4} on volume hv10_vhd NetApp was deleted by the Data ONTAP function zapi_snapshot_delete. The unique ID for this Snapshot copy is (77, 8605171).
Wed Jul  4 23:41:04 [hq-str3-a:api_mpool_01:notice]: Multicreation of snapshot named {cf161a21-6224-4105-8ba6-8638122d93b0} successful. It took 2 milli seconds from start to finish in ZAPI.
Wed Jul  4 23:41:12 [hq-str3-a:lun.offline:warning]: LUN /vol/hv10_vhd/{b8bcd75a-22a1-4ab6-a78b-e75190cbc4f3}.aux has been taken offline
Wed Jul  4 23:41:14 [hq-str3-a:lun.destroy:info]: LUN /vol/hv10_vhd/{b8bcd75a-22a1-4ab6-a78b-e75190cbc4f3}.aux destroyed
Wed Jul  4 23:43:04 [hq-str3-a:app.log.err:error]: HQ-HV13: SnapDrive 7. 1. 5. 7043: (135) Snapshot Copy event: For the description of this event please check the application event log on the host system. 
Wed Jul  4 23:43:54 [hq-str3-a:app.log.err:error]: HQ-HV13: SnapMgrServiceHost SMHV version: (106) Backup Category:  Backup of the Dataset Name: hv10 Backup id: cc37f935-43df-4a4b-91bd-a5e9c7bca748 failed to execute  Error :An error occured while renaming snapshots after backup operation.
Thu Jul  5 00:00:00 [hq-str3-a:kern.uptime.filer:info]:  12:00am up 751 days,  9:02 192673871 NFS ops, 100479298 CIFS ops, 0 HTTP ops, 0 FCP ops, 15330353377 iSCSI ops 


GetTargetLunInfo succeeded.

Storage System Name = hq-str3-a
lunPath = /vol/hv10_vhd/hv10_vhd.lun
Snapshot copy Name = {cf161a21-6224-4105-8ba6-8638122d93b0}

Failed to rename the Snapshot copy ({CF161A21-6224-4105-8BA6-8638122D93B0}_backup) of the LUN to the new Snapshot copy name (hv10_hq-hv10_HQ-HV13_07-04-2018_23.34.23_backup).

LUN Name = hv10_vhd.lun
Storage Path = /vol/hv10_vhd
Protocol Type =
Storage System Name = hq-str3-a

Error code : An attempt to rename Snapshot copy from '{CF161A21-6224-4105-8BA6-8638122D93B0}_backup' to 'hv10_hq-hv10_HQ-HV13_07-04-2018_23.34.23_backup' on volume 'hv10_vhd' failed on the storage system 'hq-str3-a'. Error code: 13021. Error description: The current snapshot does not exist.



SnapManager for Hyper-V backup failed to complete

Backup of the Dataset Name: hv10
Backup id: cc37f935-43df-4a4b-91bd-a5e9c7bca748 failed to execute
Error :An error occured while renaming snapshots after backup operation..




hq-str3-a> snap list hv10_vhd

Volume hv10_vhd

  %/used       %/total  date          name
----------  ----------  ------------  --------
  0% ( 0%)    0% ( 0%)  Jul 04 23:41  {cf161a21-6224-4105-8ba6-8638122d93b0}
  6% ( 5%)    2% ( 2%)  Jul 01 23:07  hv10_hq-hv10_HQ-HV11_07-01-2018_22.50.00_backup
  6% ( 0%)    2% ( 0%)  Jul 01 23:03  hv10_hq-hv10_HQ-HV11_07-01-2018_22.50.00
10% ( 4%)    3% ( 1%)  Jun 30 23:45  hv10_hq-hv10_HQ-HV11_06-30-2018_23.30.01_backup
10% ( 0%)    4% ( 0%)  Jun 30 23:41  hv10_hq-hv10_HQ-HV11_06-30-2018_23.30.01



I can't open a support case at this moment, because the support contract is expired.


HGS is not installed. We don't have shielded VMs. It's a crazy to install HGS/ADDS/etc on the cluster. NetApp, are you kidding ?



!!! WARNING !!!

If you are going to upgrade your cluster from Win 2012R2 to Win 2016, keep one server with Win 2012R2 in the cluster.

DON'T upgrade all nodes.