Community maintenance is complete. Thank you for your patience!

Active IQ Unified Manager Discussions

SNMP Alerts - sender is 127.0.1.1

sheelnidhig

Hello All,

 

I am using OnCommand Unified Manager for Clustered OnTap version 6.2 (vApp or .ova Deployed)

We have setup an alarm and trying to send it to a Trap receiver.

But when looking at the trap receiver, the sender is showing up as 127.0.1.1 instead of the actual server name.

 

snmp.jpg

 

Am i missing anything or this is how this bahaves ?

do we have any workaround to fix this...

 

I also tried to make sure that we have a proper DNS recored available so it should resolve to both IP and Name.

 

 

,Sheel

8 REPLIES 8

fschuber

we experience same issue after update to OCUM6.3 on vSphere App. --> Case opened 2005975735

sheelnidhig

Hello Guys,

 

I have recently seen the same issue with OCUM 7.1 and now the SNMP Trap sender is the IP address of the server and not the name or 127.0.0.1 ip.

 

I was wondering if someone have managed to identify the solution to this.

 

Thanks,

Sheel

IMHOTEPSON

me too, a solution would be nice

Midhun_Vijayan

Its a problem with SNMP v1. It is fixed for SNMPv3. But you should be having SNMPv3 trap server in your environment.

Here is the work around If you are using SNMPv1.

 

1) Boot OCUM appliance into shell prompt. How? Login to the ESX vcentre where VM resides. Take a snapshot of the VM. Proceed to launch console from vcenter. Give admin/your_password.
Go to option 4 ) Support/Diagnostics, type 'erds' in the section asks for 'Enter your choice:'. It will ask you to enter password. Set a password. Access will be enabled only for the first terminal session.
2) Login to the cli by giving username as 'diag' and the password you set above.
3) Note the IP address of the OCUM from 'sudo ifconfig'
4) edit /etc/hosts file with vi or nano
5) Set host file as below.
127.0.0.1 localhost
<ip address of the ocum> <hostname_with_fqdn> <hostname>
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
6) Reboot the ocum server.
7) Try sending alerts now. Try disabling ipv6 settings in /etc/hosts file if that's still not working.

 

Following these steps will fix the issue.

 

 

Thanks,
Midhun

SYNTAXERROR

sheelnidhig

Thanks,

this bug seems to be related to the issue i am facing. 

 

But unfortunately, i also tried to test the same with OnCommand Unified Manager 6.3RC1 and same issue.

as per the Bug this should be fixed in 6.3.

niels

Pleae re-try once you have a valid DNS entry.

The Installation guide explicitely states "...the IP address must have a valid DNS entry".

 

OCUM tries to resolve it's FQDN in order to set IP address, name and services accordingly.

 

regards, Niels

niels

Please ignore my comment.

I do have a (hopefully) correctly configured OCUM6.3RC1 running and the Trap receiver also shows 127.0.0.1 as sender...

 

regards, Niels

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public