Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Share Access Control suddenly empty

eparkaadf

Hey guys,

I was trying to setup a new backup appliance that was suppose to connect to my FAS2040 via NFS. I called Netapp support to get some info on

how I could connect to the netapp using NFS. The tech had me run the command wrfile /etc/hosts, enter in the IP address and press CtrlZ.

This overwrote everything I already had in the hosts file. I hadn't realized that it was going to overwrite and not append. The tech didn't know what to do next

so I just ran the command again and entered in all the info I had before. I cut the call short as I didn't want to run any other command.

However, I went to the Shares section under Storage and noticed that the Share Access Control for all the shares are empty.

If I try to add a user/group, it'll add but when I save it, it's blank again. I don't see how wiping the hosts file would cause this but it happened right after so

unless its a coincidence, the two are related. I called in to support again, and the tech was not helpful. At this point, I'm waiting for another netapp tech to call

but wanted to see if the forum could offer any insight as to what might have happened, and what i can do to get the netapp to show the ACLs again.

2 REPLIES 2

aborzenkov

One possibility is to revert to the last snapshot. You do have snapshots enabled for vol0, do not you?

eparkaadf

No actually we don't. The netapp was set up by a consultant. I got into this environment 2 months ago and I'm not well versed with Netapp. I was hoping techsupport could assist but that's been a challenge. I did find the CLI command to show the cifs shares and permissions. On the backend it seems that they're still there and it's correct. The GUI just won't display anything and if I try to add anything it doesn't show up. It's making me nervous.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public