Active IQ Unified Manager Discussions

Size of VSM destination created by PM

MIP_GMT01

I have a PM policy "Backup (SV) and then VSM". When I add a volume to the dataset with this policy PM creates a volume for Backup node (of the size of aggregate) and also tries to make a volume for the VSM destination of the same size as aggregate but fails because size of aggr is 53TB and maximum volume size allowed for system (FAS3240) is 50TB. Any idea what can I do to solve this problem?

1 ACCEPTED SOLUTION

adaikkap

Hi Muhammad,

                   Probably you owe me a BEER............ for all my response.

If we set this now what impact it would have on the existing secondary volumes?

No impact on the existing volumes.

After setting this option will all new volumes will be provisioned of maximum of this size and will be thin provisioned?

If DSS is disabled and this option set, then all new volumes provisioned will be to of the size of this option. By default irrespective of DSS or this option all secondary volumes are thinly provisioned.

How do you specify value for this option in KB\MB\GB\TB?

As it suggests in the option name the value should be set in MB. If you want to set it to 50GB then you would run the following cli

C:\>dfm options set pmAutomaticSecondaryVolMaxSizeMb=51200

Changed auto-provisioned secondary volume max size, in megabytes to 51200.

BTW if you want to reset or turn off this option you would do the following.

C:\>dfm options set pmAutomaticSecondaryVolMaxSizeMb=0

Changed auto-provisioned secondary volume max size, in megabytes to 0.

Regards

adai

View solution in original post

13 REPLIES 13

MIP_GMT01

By the way I am using oncommand 5.0.1 and ontap 8.1.

adaikkap

Hi Muhammad,

     As kevin said, the solution is to upgrade to OCUM 5.1 or 5.2  as we have made Dynamic Secondary Sizing for Volume SnapMirror as well.

But until you complete all your certification or if you are waiting for a GA Release you can follow the workaround in the known issue that you are hitting. I suggest you open a case and add your case to this bug 670808.

Here is the link to the bug detail that gives the workaround.

http://support.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=670808

Regards

adai

MIP_GMT01

Thank you Kevin and Adi for replies. The workaround talks about setting the dfm option pmAutomaticSecondaryVolMaxSizeMb but I don't see this option. Am I missing something?

C:\>dfm option list pmAutomaticSecondaryVolMaxSizeMb

Error: There is no pmAutomaticSecondaryVolMaxSizeMb option.

adaikkap

Hi Muhammad,

                   The options is a hidden one so until you set this option you cant list it.

PS: Setting this option will prevent PM from creating a volume greater than the value of this options. Also this is global option and applies to all.

Regards

adai

MIP_GMT01

Now it makes sense why it wasn't showing... If we set this now what impact it would have on the existing secondary volumes? After setting this option will all new volumes will be provisioned of maximum of this size and will be thin provisioned? How do you specify value for this option in KB\MB\GB\TB?

adaikkap

Hi Muhammad,

                   Probably you owe me a BEER............ for all my response.

If we set this now what impact it would have on the existing secondary volumes?

No impact on the existing volumes.

After setting this option will all new volumes will be provisioned of maximum of this size and will be thin provisioned?

If DSS is disabled and this option set, then all new volumes provisioned will be to of the size of this option. By default irrespective of DSS or this option all secondary volumes are thinly provisioned.

How do you specify value for this option in KB\MB\GB\TB?

As it suggests in the option name the value should be set in MB. If you want to set it to 50GB then you would run the following cli

C:\>dfm options set pmAutomaticSecondaryVolMaxSizeMb=51200

Changed auto-provisioned secondary volume max size, in megabytes to 51200.

BTW if you want to reset or turn off this option you would do the following.

C:\>dfm options set pmAutomaticSecondaryVolMaxSizeMb=0

Changed auto-provisioned secondary volume max size, in megabytes to 0.

Regards

adai

View solution in original post

MIP_GMT01

Perfect answers! you deserve more than one beer

MIP_GMT01

Also I see this option. Any idea would this option be useful in this situation?

C:\>dfm option list dpDynamicSecondarySizing

Option                   Value

------------------------ ------------------------------

dpDynamicSecondarySizing Disabled

adaikkap

Is there a specific reason why this options is disabled ? Ideally the value for this option should be enabled. That way you get the benefits of DSS for SV and QSM destination volumes, instead of creating aggr sized none guaranteed volumes PM will create  destination volumes, 1.32x  the total size of source volume if used space on source is <60% and 2.2x the used size of source volume if used space on source is >60%.

Regards

adai

MIP_GMT01

I guess this is disabled by default as we upgraded from previous version of DFM. If we enable this option now what impact it could have on the existing SV and QSM relationships? After setting this option enable will this only work on the newly created relationships? Does this option work only on SV and QSM not on VSM? What will happen if SV\QSM destination volume become full with dpDynamicSecondarySizing option enabled. Would destination volumes gets increased automatically?

Sorry for bombarding with so many questions

adaikkap

Hi Muhammad,

        Pls find my response to each of your questions

I guess this is disabled by default as we upgraded from previous version of DFM.

As kevin said upgrade from 3.7 or earlier will have this option disabled.

If we enable this option now what impact it could have on the existing SV and QSM relationships?

The existing secondary volume will be resized in most cases it would be downsized, the rule of thumb is for primary volume which are

  • less than 60% used then secondary volume size is 1.32x the source volume total size.
  • greater than 60% used then secondary volume size is 2.2x the source volume used size.

I just did a test to double check my memory, happy that my memory is still valid

After setting this option enable will this only work on the newly created relationships?

The answer to previous question hold good here as well. It applies to both existing and those that will get created as well but only for SV and QSM and not for OSSV or VSM

Does this option work only on SV and QSM not on VSM?

Yes it works only on SV and QSM secondary volumes and will work for VSM starting 5.1 and later, but never applies to any OSSV secondary volumes.

What will happen if SV\QSM destination volume become full with dpDynamicSecondarySizing option enabled. Would destination volumes gets increased automatically?

As said earlier DSS keeps adjusting both shrink and grow depending upon the source volume used/total as per the rule of thumb.

  • less than 60% used then secondary volume size is 1.32x the source volume total size.
  • greater than 60% used then secondary volume size is 2.2x the source volume used size.

Hope I bombarded too with answers....

Regards

adai

kryan

This option would be disabled if your server was upgraded from a version prior to DFM 3.8.

Enabling it will only affect newly created volumes, not any existing volumes.

And it will not affect VSM destinations until 5.1, where that support was added - in all previous versions of DFM/UM it only affects SV and QSM secondaries.

In versions prior to 5.1 (or 5.1 and later with DSS disabled), VSM destinations are created to the size of the containing aggregate with no guarantee, then reduced in size and expanded as needed.  The main problem with this behavior is the limit of how large a volume can be versus the aggregate size, which is the issue you are running into.

kryan

Upgrade to UM 5.1 or 5.2RC1 where it uses DSS (Dynamic Secondary Sizing) for VSM volumes. 

This will prevent it from attempting to create it to the size of the containing aggregate.

WARNINGS:

  • Always create a backup (dfm backup create) prior to upgrading. 
  • When upgrading to 5.1 or later you must choose a mode for UM to operate in (7DOT or cDOT) - if you have both modes in your environment you need two servers for UM. 
  • UM 5.2 and higher will only be delivered as 64 bit.
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

Public