Active IQ Unified Manager Discussions

Upgrade from NMSDK 5.4 to 5.7 (HTTP not working)

muditag85
3,495 Views

Hi,

 

I recently upgraded my setup with nmsdk 5.7 version.

 

This sdk is talking to a 8.1.1 7-Mode filer.

 

After upgrade I am seeing that I am no longer able to connect to the 7mode filer over "HTTP" port.

 

Getting following error:

 

'No permission to use 'hostsequiv' authentication, must be root.

 

But with same credentials (and any other change) I am able to connect it over "HTTPS" port

 

 

options tls.enable is on (if it is off it fails for "HTTPS" too.

Is this issue with SDK upgrade or something else? Please help.

 

Thanks

Mudit

 

1 ACCEPTED SOLUTION

Abhilash
3,418 Views

Hi,

 

 

NMSDK has moved to default HTTPS behavior from NMSDK 5.5.


To use HTTP we have to change the Transport type to “HTTP” and port to “80”

---------------------------------------------------------

In case of C/CPP:
Before creating new server connection we have to set transport type and port:below Example

transport = NA_SERVER_TRANSPORT_HTTP;
use_port = 80;
s = make_server(host, NA_SERVER_TYPE_OCUM,
user, passwd, transport, apistyle, use_port, vfiler_name);

-----------------------------------------------------------

In case of Perl:

$s->set_port(80)
$s->set_transport_type("HTTPS");
-----------------------------
likewise we can do for the language too.

 

 

Regards,

Abhilash

View solution in original post

5 REPLIES 5

Abhilash
3,419 Views

Hi,

 

 

NMSDK has moved to default HTTPS behavior from NMSDK 5.5.


To use HTTP we have to change the Transport type to “HTTP” and port to “80”

---------------------------------------------------------

In case of C/CPP:
Before creating new server connection we have to set transport type and port:below Example

transport = NA_SERVER_TRANSPORT_HTTP;
use_port = 80;
s = make_server(host, NA_SERVER_TYPE_OCUM,
user, passwd, transport, apistyle, use_port, vfiler_name);

-----------------------------------------------------------

In case of Perl:

$s->set_port(80)
$s->set_transport_type("HTTPS");
-----------------------------
likewise we can do for the language too.

 

 

Regards,

Abhilash

muditag85
3,388 Views

Thanks a lot Abhilash, it worked.

muditag85
3,294 Views

Hi Abhilash,

 

Sorry to bother you again but this solution is not working with NFS exports.

 

I am getting following error even after setting transport type to NA_SERVER_TRANSPORT_HTTP only in case of NFS (its working for iSCSI):

 

Error: 111

 

Thanks

Mudit

muditag85
3,244 Views

Hi Abhilash,

 

Please ignore my previous comment but I am still facing the issue with HTTP/80 but only with ONTAP 9.2 

 

ONTAP 9.1 is working fine both for HTTP and HTTPS

 

Thanks

Mudit

deepj
3,204 Views

Hi 

 

May I know which platform and language are you using?

 

Thanks & Regards

Deep

Public