If you missed the pre-registration for NetApp MS Azure AD B2C, the new login prompt will offer the option to register. Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

OCUM 7.0RC1-Invalid links in Email Alert

JPick

Two instances of UCUM 7.0RC1 are exhibiting the same behavior.  When an alert is sent to an email, the event details link to https://localhost:443/um/.......(see attachment for screenshot).  I assume "localhost" should have the name of the UCUM or OPM server.    Prior to upgrading from 6.x, when an alert was sent to email, I was able to click on the event details link, which would then connect me to OCUM or OPM, and view the alert.  Any ideas?

 

-Thanks.

1 ACCEPTED SOLUTION

msaravan

Sorry for the delay. Can you please reset the hostname using "um option" command.

 

Steps to fix this problem:

 

* Go to the console (root console)

* Login to "um cli"

* Set the custom.hostname option to the new value for whcih DNS works

* restart the ocie service

 

 

The commands for the above steps are shared below.

 

um cli login -u <user_name> -p <pwd>
um option set custom.hostname=oncommand-71rc1-168.gdl.englab.netapp.com

service ocie restart

 

 

Let me know if that doesnt work.

 

Regards,

Saravanan

View solution in original post

20 REPLIES 20

wmy_pm

Hi

 

I have the same problem here with OCUM 7 ESX applinace. I don't have a way to get to um command prompt.

Anybody have the fix for this issue?

 

Thank you!

cprivitere

I had the same issue (localhost in links in the emails) and I was able to open a ticket with support and they were able to walk me through the steps quite easily (after we got it escalated a couple levels, that is). It involves a special mode accessed in the maintenance menu that gets you in as root that they only let you know about when you need support. So just open a ticket and they'll get you sorted out.

hey cprivitere

 

i'm glad your support could help you in this case. Unfortunately I'm not that lucky for now.

Can you let me know how to get to this special root login?

 

Thanks, Michael

ok just figured it out:

 

In the Main Menu, type 4 to select Support/Diagnostics.To access the diagnostic console, in the command prompt type erds.
You are prompted with the following message:Remote diagnostic access is disabled. Would you like to enable remote diagnostic access? (y/N).
Type y to enable remote diagnostic access.When prompted, enter a new UNIX password for the diagnostic user.Type x to exit from the maintenance console.
Log in to the maintenance console with diag as the user name and the new UNIX password that was set in Step 11.

 

thanks anyway, now all works fine for me.

wmy_pm

Works for me too.

 

Thank you!

wmy_pm

Thank you! 

I just opened a case with them.

michael_trutmann

same problem here. someone found a solution?

thanks

Albrecht

Hello all,

 

we do have the same issue - even running OCUM 7.0 GA.

 

Risk          - Aggregate Nearly Overcommitted

Impact Area   - Protection

Severity      - Warning

State         - Obsolete

Source        - XX

Trigger Condition - XX

 

Event details:

https://localhost:443/um/#event-details:event-id=401596

 

Source details:

https://localhost:443/um/#aggregate-details:aggregate-id=726

 

Alert details:

https://localhost:443/um/#alerts:alert-id=2001

 

 

 

 

Solution would be very much appreciated!

 

Best regards

Albrecht

msaravan

Sorry for the delay. Can you please reset the hostname using "um option" command.

 

Steps to fix this problem:

 

* Go to the console (root console)

* Login to "um cli"

* Set the custom.hostname option to the new value for whcih DNS works

* restart the ocie service

 

 

The commands for the above steps are shared below.

 

um cli login -u <user_name> -p <pwd>
um option set custom.hostname=oncommand-71rc1-168.gdl.englab.netapp.com

service ocie restart

 

 

Let me know if that doesnt work.

 

Regards,

Saravanan

View solution in original post

John_Stoffel

So what do can I do if I'm running OnCommand Manager as the VM deployed image, and not in a Linux or Windows system?  How do I fix this issue then?

 

 

Aps

The oc um command seems invalid in 7.2.

 

Main Menu
---------
1 ) Upgrade (Disabled. Must be run on virtual machine console.)
2 ) Network Configuration
3 ) System Configuration
4 ) Support/Diagnostics
5 ) Reset Server Certificate
6 ) External Data Provider
7 ) Performance Polling Interval Configuration
8 ) Migrate Data from OnCommand Performance Manager 7.1

x ) Exit

Enter your choice: um cli login -u -p XXXXXXX

Invalid response.
OnCommand Unified Manager Maintenance Console

 

Ok, so lets try the menu, found a hostname entry:

 

System Configuration Menu
-------------------------
1 ) Display Server Status
2 ) Reboot Virtual Machine
3 ) Shut Down Virtual Machine (Disabled. Must be run on virtual machine console.)
4 ) Change 'admin' User Password
5 ) Increase Data Disk Size
6 ) Increase Swap Disk Size
7 ) Change Time Zone
8 ) Change NTP Server
9 ) Restore from an OCUM Backup
10 ) Change hostname

b ) Back
x ) Exit

Enter your choice: 10

This will change your hostname, which will reset your network connection
Hostname : nas-ocum-prod-1201

 

That is the correct hostname, but the emails still have localhost in the links. I just upgraded the system to 7.2, and the links came through properly before the upgrade, but now show localhost.

 

nas-ocum-prod-1201@rhapsody.com
6:25 AM (8 minutes ago)

to techops-se
A risk was generated by localhost that requires your attention.

Risk - LIF Not At Home Port
Impact Area - Availability
Severity - Warning
State - Resolved
Source - nas_prod:nas-sea2-03-vmds
Trigger Condition - The current port nas-sea2-04:a0c-33 that is associated with the LIF is different from the home port nas-sea2-03:a0c-33.

Event details:
https://localhost:443/#/all-events/30012

Source details:
https://localhost:443/#/health/svms/231213?tabid=lifs&tabtype=lif&tabtypeid=231226

Alert details:
https://localhost:443/#/alerting/1

 

 

Any ideas?

niels

Hi Aps,

 

the "um cli login" command does exist in UM 7.2, but you tried at the wrong place. You need to drop to the DIAG shell in order to do this.

Please follow the steps in this KB article to get to the DIAG shell:

https://kb.netapp.com/support/s/article/How-to-access-the-OnCommand-Virtual-Machine-DIAG-shell

 

The problem of the host being identified as "localhost" and its remidiation is described here:

https://kb.netapp.com/support/s/article/Unified-Manager-Alert-Notifications-reflect-server-names-as-localhost-in-URL-links

 

regards, Niels

 

-----

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both.

MisterBrown

Hello

 

Thanks for your tipps...

 

I habe the OCUM installed on a windows Server, i found out i can do these commands in the adminstratos CMD

But the service ocie restart did not work, so i restarted the the whole Server

 

But my customer asked ma and he use the vsphere Appliance.

Do he have to login with ssh?? in console from vsphere client he just get the text emnu to use.

 

Thanks for more details ...

 

Regards from Switzerland .. Udo

niels

Thanks - worked for me.

I changed the following options to reflect the actual FQDN rather than "localhost":

 

autosupport.fromAddress
custom.hostname 
email.fromAddress
protection.wfa.um.datasourceName
quotaEmail.format.from    

 

Unfortunately the manual restart of the ocie service did not succeed. I had to restart the vApp but all is fine now.

 

regards, Niels

 

rezkmekhael

do the following 

 

ssh admin@ocum

 

 3 ) System Configuration

 

          11 ) Change hostname

          10 ) Reset Server Certificate

reboot

JPick

Hi PierreC.  I do not have a solution for this.  I am urging my customer to open a ticket.  This has not yet been done.  

 

-Thanks.

niels

I also observed that OCUM registeres in WFA with the localhost address. I had to change the data source in WFA manually afterwards to reflect the right name/IP.

So this seems to be a general problem in 7.0RC1.

 

regards, Niels

msaravan

Is your setup running in Windows or Linux or vApp?

 

If it is running on Windows or Linux, can you paste the output of following commands:

 

* hostname

* ping <hostname>

* pint -a <ip_address>

 

I do have a workaround for this issue, and the above output would help me to validate that.

 

 

Regards,
Saravanan

JPick

It is a vApp.  Will the proposed workaround still work?  If so, please share.

 

-Thanks.

PierreC

Hello,

 

Do you have a solution for this issue ?

I'm facing the same problem.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

Public