Active IQ Unified Manager Discussions

WFA 2.0 create vserver workflow



Just intstalled wfa 2.0 and checking out the workflows in my lab environment. the "create and configure new nas vserver" workflow does not list my cluster in the drop down box. other workflows list my cluster in the dropdown box, for example the "create a cluster-mode nfs volume" lists my cluster in the drop down.

Anyone have ideas on how to troubleshoot this?


Re: WFA 2.0 create vserver workflow


I think your cluster doesn't have the necessary NAS license installed and hence WFA is rejecting it as a cluster on which a NAS vserver can be created. Kindly check your license on you cluster using command "license show"

There are other parameter checks as well, lets try to see those once we are confirmed on the license part.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: WFA 2.0 create vserver workflow


thanks but i validated i have those licenses installed, i should have mentioned that in my original post

they are demo licenses and expire 6/2/2014

Re: WFA 2.0 create vserver workflow



Please could you execute the filter "Filter clusters by license" and provide the input to this filter as "nfs". The result of this filter execution should display your cluster.

If not, please re-acquire the relevant data source and run the filter again.




Re: WFA 2.0 create vserver workflow


thank you, i tried the filter and my cluster didnt display. i went ahead and got some new licenses for my cluster and they are now listed as site licenses with no expiration, i updated my data source acquisition interval to 1 minute and allowed it to run a few times then i tried the filter and the workflow again but still my cluster is not showing.

Re: WFA 2.0 create vserver workflow


Hi Aaron,

Can you provide more details on the data source you have configured on WFA. Which version of OnCommand Unified Manager is it?

Also, are the licenses discovered and listed appropriately in OnCommand Unified Manager?


View solution in original post

Re: WFA 2.0 create vserver workflow



About DataFabric® Manager server
Version (5.2RC1)
Executable Type     64-bit
Serial Number     1-50-000011
Edition     Standard edition of DataFabric Manager server
Data ONTAP Operating Mode     Cluster-Mode

i refreshed the monitoring sample and made sure that completed then i ran a cluster licenses report in DFM but it reports " there are no licenses" so thats probably part of the problem

also i set my ocum data source in wfa to refresh every 1 minute- i also verified the success of each refresh cycle.

at this time no clusters appear in the "create nas vserver" workflow

Re: WFA 2.0 create vserver workflow


Turns out DFM was not collecting all data from the cluster. even though i was able to report on the cluster in dfm and dfm was aware about most of the cluster the licensing was not appearing in dfm and i found an error saying "host login failed" in dfm for the cluster. i went to the options in dfm for the cluster and entered the cluster username and password then refreshed the data and was able to see the licensing details in the licensing report. wfa now displays the cluster in the create nas vserver workflow.

thanks everyone

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums