Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

WFA 2.0 install error

carmine

I'm trying to install WFA 2.0 in our lab, and as soon as I accept the license agreement, and it starts the install process, it errors out with the following error "Setup cannot continue, the following TCP ports are busy : HTTP (80)" (screenshot attached)

I'm running Win 2008 server in a VM.  Windows firewall is disabled, and I'm able to surf the internet.  Has anyone come across this issue?

Any guidance would be appreciated,
Carmine

1 ACCEPTED SOLUTION

sharu

Hi Carmine,

Please try stopping the service 'World  Wide web publishing service' on your Win 2k8 VM and start the WFA installation again. This is because the web publishing service also by default runs on port 80.

-Sharu

View solution in original post

5 REPLIES 5

yaronh

I'd check if the IIS is up.

If so - just remove the role. Should be fine afterwards.

Yaron

sharu

Hi Carmine,

Please try stopping the service 'World  Wide web publishing service' on your Win 2k8 VM and start the WFA installation again. This is because the web publishing service also by default runs on port 80.

-Sharu

View solution in original post

carmine

Thank You!!! This worked perfectly!!

kandati

Make sure to disable the service or change it to Manual start-up. Otherwise in the next WFA installation time or if the server gets rebooted then the same service will start utilizing that port and WFA server will not be accessible.

Warm Regards

Sivaprasad K

kandati

Hi,

Try to follow what ever Sharu has suggested..!

If that is not solving your problem then try to follow the below steps to make port 80 free for WFA,

1)Execute the following command to list which PID is consuming the port:80

# netstat -aon|findstr 80

  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       1400  <<<<<<----------------------

  TCP    0.0.0.0:5800           0.0.0.0:0              LISTENING       1692

  TCP    0.0.0.0:8009           0.0.0.0:0              LISTENING       1400

  TCP    0.0.0.0:8081           0.0.0.0:0              LISTENING       1252

  TCP    0.0.0.0:8083           0.0.0.0:0              LISTENING       1400

  UDP    0.0.0.0:8081           *:*                                    1252

  UDP    0.0.0.0:8082           *:*                                    1252

  UDP    127.0.0.1:1380         *:*                                    5324

Here Port:80 is consumed by PID:1400

2) Then try to list the process with PID :1400

#tasklist|findstr 1400

NA_WFA_SRV.exe                1400 Console                    0    700,116 K

In my case, its WFA server.

In your case, it would be different service/process. So, go to services page and stop the service and make it disabled by setting the startup-type in the properties.

Now, your WFA installation would be smooth..!

Hope it helps..!

Warm Regards

Sivaprasad K

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public