Active IQ Unified Manager Discussions

WFA 2.2

aparker

Do anyone know when 2.2 is supposed to be GA?

7 REPLIES 7

korns

A related question is why can't WFA 2.2 Exported Workflows be imported into 2.1?

I've upgraded my dev-lab environment to 2.2RC1 and attempted to export/import some workflows into a v2.1 environment but it failed. Is there any chance this was a mistake or is the rule that imports must always come from the same or older WFA version? This could become a major hassle as folks are managing multiple project for multiple customers.

Dave

PS: of course I'm only assuming/expecting 2.1 functionality when I import a 2.2 workflow into 2.1

adaikkap

Hi Dave,

Can you share the .dar file ? So that we can look into the cause of failure ?

Importing  of a .dar file should work across any version of WFA and there is no requirement that it always has to be higher.

Regards

adai

korns

Adai, ... I tried three more things to see if I could narrow down the problem but no luck:

1) I attempted a simpler export-2.2/import-2.1 of just a single workflow. As I mentioned, the original dar file I attempted to import was a complete Category and all it's member workflows and their dependencies. I picked one of those 4 workflows and attempted to import just it (and it's dependencies). No luck, same error as above.

2) I attempted to export-2.2/import-2.1 something entirely different (a datasource and dependent dictionary). Got the same error as above doing that.

3) I attempted to export-2.2/import-2.1 a single workflow which was in my wfa-2.2 environment but hadn't been touched since wfa-2.1. it was built/edited back when I was running wfa-2.1). This wouldn't import into 2.1 either and gave the same error as above.

pavila

Hey Dave!! Are they not backward compatible or is it only when you are importing/exporting from 2.2 to 2.1??

korns

From the latest information I have received it seems WFA  dis-allows importing .dar files created with higher WFA version numbers. I think it may have always been that way. That is probably the safest and easiest way to ensure what is being imported doesn't have new-unknown-unsupported features.

korns

Really, that's good to know. But it doesn't explain my problem.  I sent you the dar file as a direct email. The WFA v2.1 error I got is shown in attachment

abhit

2.2GA is expected around June-July 2014.

Regards

Abhi

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public