Active IQ Unified Manager Discussions

WFA 4.1 Can't get to work Post API request

jivam

Can't get to work the Post call against WFA API using a perl script

 

it works when using curl

 

below is the output

 

HTTP::Response=HASH(0x1e40560)
'_content' => 'Cannot consume content type'
'_headers' => HTTP::Headers=HASH(0x1e40530)
'cache-control' => 'no-cache, no-store, must-revalidate'
'client-date' => 'Tue, 10 Apr 2018 19:16:52 GMT'
'client-peer' => 'xx.xx.xx.xx:443'
'client-response-num' => 1
'client-ssl-cert-issuer' => '/O=of/OU=Bank/CN=fqdn.com'
'client-ssl-cert-subject' => '/O=of/OU=Bank/CN=fqdn.com'
'client-ssl-cipher' => 'EDH-RSA-DES-CBC3-SHA'
'client-ssl-warning' => 'Peer certificate not verified'
'connection' => 'keep-alive'
'content-length' => 27
'content-type' => 'text/plain'
'date' => 'Tue, 10 Apr 2018 19:16:52 GMT'
'expires' => 0
'pragma' => 'no-cache'
'server' => 'WildFly/8'
'set-cookie' => ARRAY(0x1e40800)
0 'JSESSIONID=KHDkT_8NNEXHTp14gEJ_8q2P.elabvmte04; path=/rest; HttpOnly'
1 'JSESSIONIDSSO=o53n6_NLSAKMfihL5a8bDthH; path=/'
'x-powered-by' => 'Undertow/1'
'_msg' => 'Internal Server Error'
'_protocol' => 'HTTP/1.1'
'_rc' => 500
'_request' => HTTP::Request=HASH(0x16d7000)
'_content' => '<?xml version="1.0"?>
<workflowInput>
<userInputValues>
<userInputEntry key="VserverName" value="8060svm"> </userInputEntry>
<userInputEntry key="ClusterName" value="8060"> </userInputEntry>
<userInputEntry key="VolumeSizeInGB" value="10"> </userInputEntry>
<userInputEntry key="VolumeName" value="Vol1"> </userInputEntry>
</userInputValues>
</workflowInput>
'
'_headers' => HTTP::Headers=HASH(0x16d5fc8)
'authorization' => 'Basic YWRtaW46QWRtaW4xMjM='
'content-length' => 389
'content-type' => 'application/x-www-form-urlencoded'
'user-agent' => 'libwww-perl/5.831'
'_method' => 'POST'
'_uri' => URI::https=SCALAR(0x1b6d898)
-> 'https://xx.xx.xx.xx/rest/workflows/76b936ba-d52e-4304-b562-01676d35ad43/jobs'
'_uri_canonical' => URI::https=SCALAR(0x1b6d898)
-> REUSED_ADDRESS

2 REPLIES 2

paragp

Your response says _content' => 'Cannot consume content type'  . For xml input the Content-Type should be application/xml

 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

Public